Linux 3.11_rcX compatibility

Just patched the 325.08 driver to get compiled against 3.11_rc1. I made two patches. One includes the 3.10 patch, and the other is incremental to it.

WARNING:
I am not very familar with nvidia-drivers code and/or kernel code. So I really do not know what my patch exactly does. My GPU reports some degrees more temperature with it applied. But actualy it is running! Well, you have been warned.

Edit:
Sorry, no .patch file extension allowed here. So I added .txt! ;)
nvidia-drivers-linux-3.11-incremental.patch.txt (842 Bytes)
nvidia-drivers-linux-3.11-full.patch.txt (18.4 KB)

root@sdrbox:/usr/src/NVIDIA-Linux-x86_64-325.08# grep GPL /var/log/nvidia-installer.log
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol ‘mutex_lock_nested’

3.11.0-rc1 latest git.

I wonder where NVIDIA devs are.

For the past two weeks I haven’t seen a single message from them.

Your error is caused by the extra debugging symbols in the git kernel, build a nodebug kernel and it should work.

Here’s a link to the patch I used (works with 3.10.0 and 3.11.0 rc1)

http://cvs.rpmfusion.org/viewvc/checkout/rpms/nvidia-kmod/devel/kernel_v3.10.patch?revision=1.4&root=nonfree
kernel_v3.10.patch.txt (17.3 KB)

CONFIG_DEBUG_KERNEL gets turned on automatically. If it’s edited out as “is not set” in .config it gets turned on again.

The .config is the same as I have used with all previous kernels up to 3.10.0.

Rather than a kernel config problem it’s something that the patch doesn’t take care of.

Also affects 3.11.0-rc2.

Here is the nvidia 319.49 patch for kernel 3.11

http://sourceforge.net/projects/openpctv/files/sources/nvidia-319.49_kernel-3.11.patch/download

In the past post here, i read that

Linux 3.11_rcX compatibility
Your error is caused by the extra debugging symbols in the git kernel, build a nodebug kernel and it should work. Here’s a link to the patch I used (works with 3.10.0 and 3.11.0 rc1) http://cvs.rpmfusion.org/viewvc/checkout/rpms/nvidia-kmod/devel/kernel_v3.10.patch?revision=1.4&root=nonfree
Posted in Linux

Then i uncheck the option “debug kernel” in kernel hacking with make menu_config
with the last 3.15 kernel, re compile and boot this new compilation and i can
install the nvidia driver, this option block the nvidia driver and solve the issue

OS: Slacware updated 14.1
Nvidia Driver: 331.79

thanks a lot