Linux Driver 390 works, 396 doesn't

(I posted this on the user forums first, but was told to ask here)

Card: GTX 1060 6GB (Palit)
Screen: Philips PHL BDM4350 (43" 3840x2160)
Connection: HDMI 2.0

I use the PPA ‘graphics-drivers’ on Ubuntu 16.04 (HWE kernel 4.13). I now tried to update the driver from 390.48 to 396.24.

The system boots, boot screen is visible, but as soon as it is about to switch to native resolution (I guess that’s when the driver is loaded?), the screen looks like this: https://imgur.com/a/yB0TTki
Switching to another TTY doesn’t work either, the system is unresponsive.

I reset, boot in recovery mode, revert to 390.48, and it works fine again. Tried again with 396.24, same result. Reverted to 390.48, works again. Seems 100% reproducible.

I installed a fresh Ubuntu 18.04 (kernel 4.15) to another disk, added the PPA, and it’s the same result: 390 works, 396 doesn’t.

I switched my screen from HDMI 2.0 to 1.4. Works with 390 (at 30hz), doesn’t at all with 396.

I connected the screen via DisplayPort. Works with 390, doesn’t with 396.

I attached an older Dell Screen (24" 1920x1200) and tried again. The result is the same: It works fine with 390, and does not with 396 (except the screen stays black on the Dell instead of a broken image like on the Philips).

I checked the system messages of both boot processes, and all NVIDIA related messages are pretty much the same for the 390 boot and the 396 boot. The only difference is this line, which only is written on the (successful) 390 boot:

kernel: [   10.074970] nvidia-modeset: Allocated GPU:0 (GPU-f30f79cc-0755-2581-03e0-284d0007b39a) @ PCI:0000:01:00.0

So I seem to have eliminated as a problem source:

  • the screen (tried 2 completely different screens)
  • the connection (tried both HDMI and DisplayPort, and DVI on the Dell)
  • the operating system (tried on Ubuntu 16.04, as well as on a clean 18.04)

What’s left? Maybe mainboard? Firmware is up to date. What’s different between 390 and 396? Does the new driver use new features that require special BIOS/UEFI settings? (It’s an ASRock Z370 Extreme 4 with an Intel i5 8400 CPU)

Any ideas?

Update: I did a manual install of the 396.24 driver downloaded from the NVIDIA site, with the same results. So it seems not to be the PPA driver either.

Hi.

Please see my thread

https://devtalk.nvidia.com/default/topic/1032725/linux/396-18-02-neon-sddm-crash-on-boot-xid-62-nvrm-rm_init_adapter-failed-for-device-bearing-min-/

I and others have exact same issue.

If you read through the thread Nvidia are now tracking the issue, please include a bug report in this thread.

It looks like this is a Palit 1060 specific issue.

I got a bug report (as you have to get one with the ‘bad’ driver) by reverting back to nvidia-390 (rescue mode, etc) then installing and enabling openssh.

Then went back to 396.x, and went to the commodore64 loading screen type graphics (i.e the above screen shot) Then logged in via another device to run the nvidia bug report.

I can confirm that I have the exact same issues on my PNY GTX 1060 6GB (Palit). Installing 396.24 causes problems, rolling back to 390.48 fixes the issues. I’ve tried installing the Nvidia drivers on Fedora 28 and Ubuntu 18.04. For now I guess I have to stick with 390.48…

Known problem, bug reports wanted:
https://devtalk.nvidia.com/default/topic/1032725/linux/396-18-02-neon-sddm-crash-on-boot-xid-62-nvrm-rm_init_adapter-failed-for-device-bearing-min-/
Post there, run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

I would like to add that this issue is also for the NVIDIA gtx 1060 3gb model from palit - same happens with the 396.xx drivers as in the screenshot from poster #2 Only solution at the moment is to use the 390.xx drivers

OS: Ubuntu 18.04
DE: Gnome
GPU: NVIDIA GTX 1060 3GB (Palit)

@alex7r6xb + @rstrube + @TheMUVP

Please upload a bug report to this thread

https://devtalk.nvidia.com/default/topic/1032725/linux/396-18-02-neon-sddm-crash-on-boot-xid-62-nvrm-rm_init_adapter-failed-for-device-bearing-min-/

The sooner you all do this, the sooner this may be fixed…

Done: https://devtalk.nvidia.com/default/topic/1032725/linux/396-18-02-neon-sddm-crash-on-boot-xid-62-nvrm-rm_init_adapter-failed-for-device-bearing-min-/post/5259250/#5259250