Linux driver 418.56, GTX 1660 Ti, NVRM: RmInitAdapter failed!

I tried to plug a GTX 1660 Ti to an Onda D1800-BTC motherboard with nvidia driver 418.56 along side Ubuntu 18.04 system installed. But I got “RmInitAdapter failed!” error from dmesg. “nvidia-smi” did not show this card, while other card of GTX 10 series works well. I really do not know what’s the reason of this.
As a similiar problem with thread “
I’ve also tried to put “mem_encrypt=off” option to grub, but no luckiness.Can anyone give a hint to me?

$ dmesg | grep NVRM
[ 25.476919] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 418.56 Fri Mar 15 12:59:26 CDT 2019
[ 35.452713] NVRM: GPU at PCI:0000:06:00: GPU-978e3990-0cfa-5206-2ff0-6684c7fcb80a
[ 35.452716] NVRM: GPU Board Serial Number:
[ 35.452721] NVRM: Xid (PCI:0000:06:00): 61, 0c06(3030) 00000000 00000000
[ 56.382387] NVRM: RmInitAdapter failed! (0x24:0x65:1070)
[ 56.382915] NVRM: rm_init_adapter failed for device bearing minor number 0

Turing series gpus often fail to initialize when there’s only pcie gen1 available which is often the case with mining boards. Check if you can set the slots to pcie gen2.

I don’t think it has anything to do with his motherboard. I’m getting the exact same problem in Ubuntu 16.04 with a different motherboard. I’m running driver version 418.56 on Ubuntu 16.04 and I’m getting the same Xid with the same error codes when I put in my new GTX 1660. My GTX 950 runs fine with the same configuration.

Please temporarily install Windows 10 and verify the GPU works in it. Also check if the GPU survives running FurMark for at least a few minutes.

The board Onda D1800-BTC has 6 pice slots, while in bios there are only 4 option slots for generation configuration. I tried to set all of them to gen2, but still the same issue.

I’m also using GTX 1660 Ti on another board of Asus Z8PE-D12. Not directly, but passthrough to a KVM virtual Machine of Ubuntu 18.04. The system recoginized it successfully. No issue was discovered. BTW, the host system is OpenSuse Leap 42.3.

I’ve tried Windows 10, GTX 1660 Ti is successfuly recognized. But FurMark crashed with it. It’s strange that if I have more than 1 card plugged, I furmark could render it on GTX 1660 Ti while output on another card hdmi port. Byt the framerame only reached an average of 6. With mining software, the hashrate of this card is signifcantly lower than expected.

The rminit message points to a failure in an early pcie init stage and taking the results from using Windows into account, I’d say the quality of the pcie busses does not suffice for a Turing card. You can only check with the manufacturer for a bios update but outlook is bad.

My motherboard is a gen2 pcie slot. I don’t understand the requirement. Is there a list of known compatible motherboards? I’ve used NVidia GPUs for over a decade and I’ve never run into anything like this with an NVidia card. This doesn’t bode well in my opinion.

Since the GPU doesn’t work well under Windows yet works on different motherboards then your MB is most likely faulty/non-compliant and people at this forum hardly can help you. Time to swap your motherboard.

Also make sure your PSU is OK and the GPU power cable delivers enough juice.