Linux Graphics debugger Showing Qt platform plugin "xcb" not found

At the time of launching the application for debugging i am getting this message,

This application failed to start because it could not find or load the Qt platform plugin “xcb”
[Gui5] in “”.
[Gui5] Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
[Gui5] Reinstalling the application may fix this problem.

I tried every possibility with library dependencies there are two libs
on doing ldd on ./nvidia-gfx-debugger
but the files are already there

my os-ubuntu 64bit,

Hi saikumar,

What is the result of “ldd ./Plugins/platforms/” ?
When you launch the application, do you execute ./nvidia-gfx-debugger or ./nvidia-gfx-debugger.bin ? Normally, executing ./nvidia-gfx-debugger is the way to launch LGD.


Thanks codym_nv,
ldd on found every thing no problems with library dependencies, and i am using ./nvidia-gfx-debugger to open LGD, and LGD opens fine but when i launch my application to debug it is showing the above xcb not found error

Hi there,

Can you try launching other applications in LGD? For example, glxgears in mesa-utils package.

If possible, please share your sample application with us, so we can try to reproduce the issue.

Also, we need more information such as:

  • Ubuntu version
  • GPU
  • Graphics driver version
  • LGD version


Opened glxgears and debug too is running fine,
Ubuntu version->16.04
drivers nvidia->370.28

Hi there,
Looks like it’s app specific issue. Could you share your application with us?

hai again,
The problem is specific to Qt Applications, Tried even reinstalling Ubuntu and started once again, it works with glut and sdl,
And here is my project

We tried your application on a Ubuntu 16.04 machine. Without LGD, the application launches with the error “xcb not found”.
Can you confirm it runs fine on your machine without LGD?


Yes it runs fine without Linux Graphics Debugger, if qt is installed


Here’s an update on your issue:
LGD 2.0 was built with Qt5.5 and your application is using Qt5.7.
You can try to launch your application in command line, then attach to it with LGD.

  1. LD_PRELOAD=~/.tgd/lib/

  2. in LGD, “Connect” button, “Attach” tab, select your app process, then “Attach” button.

Hope this will solve your issue.

hai codym_nv,
still it is not working, attach tab showing no attachable process found


Please give detailed steps of how you launch your application.

Also a screenshot including terminal window, LGD and your application should be more helpful to solve your issue.


Tried with multiple changes, it is working now, by starting the application from the folder where is there
like this

sudo LD_PRELOAD=./ /home/saikumar/Documents/Gui5/build-Gui5-Desktop_Qt_5_7_0_GCC_64bit-Debug/Gui5


I can’t see the images, but glad to hear it’s working :)