Linux Kernel 5.8.0 rc-3.1 breaks nvidia driver

I compiled kernel 5.8.0 rc-3.1 and tried to get nvidia beta drivers 450.51 from aur(nvidia-beta the dkms branch) and I got this error https://pastebin.com/raw/6jjxcYZE . The commit that breaks vmalloc() is this one here https://github.com/torvalds/linux/commit/88dca4ca5a93d2c09e5bbc6a62fbfc3af83c4fca

Commit da1c55f1b272f4bd54671d459b39ea7b54944ef9 is also a problem to get the driver to compile.

As you seem to already be using Tk-Glitch’s kernel, consider using the nvidia-all package as well.

I posted the below which was with the 450.51 driver, and it fails as well.
I’m running Fedora 31. Just tried the beta driver, NVIDIA-Linux-x86_64-450.51.run with vmlinuz-5.8.0-0.rc3.20200630git7c30b859a947.1.vanilla.1.fc32.x86_64
I tried to install running NVIDIA-Linux-x86_64-450.51.run --kernel-source-path=/usr/src/kernels/5.8.0-0.rc3.20200630git7c30b859a947.1.vanilla.1.fc32.x86_64/
The last thing that works for me is NVIDIA-Linux-x86_64-440.82.run with vmlinuz-5.7.0-0.rc0.git6.1.vanilla.knurd.1.fc31.x86_64
I’m attaching the log file from the latest attempt. Any suggestions most welcome.nvidia-installer.log (1.2 MB)
Thanks,
Fred

Edited to add first error message, which is:

In file included from /tmp/selfgz1307/NVIDIA-Linux-x86_64-450.51/kernel/nvidia/nv-front
end.c:13:
/tmp/selfgz1307/NVIDIA-Linux-x86_64-450.51/kernel/common/inc/nv-linux.h: In function ‘n
v_vmalloc’:
In file included from /tmp/selfgz1307/NVIDIA-Linux-x86_64-450.51/kernel/nvidia/nv-acpi.
c:15:
/tmp/selfgz1307/NVIDIA-Linux-x86_64-450.51/kernel/common/inc/nv-linux.h: In function ‘n
v_vmalloc’:
/tmp/selfgz1307/NVIDIA-Linux-x86_64-450.51/kernel/common/inc/nv-linux.h:508:17: error: too many arguments to function ‘__vmalloc’
508 | void *ptr = __vmalloc(size, GFP_KERNEL, PAGE_KERNEL);

The driver needs to be patched on the 5.8 kernel. For Arch I recommend the above package, for Fedora you’ll need to manually patch the driver.

Edit: The instructions is for the 440.100 version of the driver, but it works for the 450.51 series as well, just change the referenced name.

Does Nvidia have a tenth of a person that cares about Linux? If so perhaps that person could give a hand here.

$ inxi -GS
System:    Host: leigh Kernel: 5.8.0-0.rc3.20200630git7c30b859a947.1.fc33.x86_64 x86_64 bits: 64 
           Desktop: Cinnamon 4.6.5 Distro: Fedora release 33 (Rawhide) 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 450.51 
           Display: x11 server: Fedora Project X.org 1.20.8 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.51 

The patch works for me

https://download1.rpmfusion.org/nonfree/fedora/development/rawhide/Everything/x86_64/os/repoview/akmod-nvidia.html

1 Like

I appreciate the patch, but evidently I have a lot to learn in order to take advantage of it. I tried
rpm -U /f/Downloads/akmod-nvidia-450.51-2.fc33.x86_64.rpm
and got
warning: /f/Downloads/akmod-nvidia-450.51-2.fc33.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID 94843c65: NOKEY
error: Failed dependencies:
nvidia-kmod-common >= 3:450.51 is needed by akmod-nvidia-3:450.51-2.fc33.x86_64
xorg-x11-drv-nvidia-kmodsrc >= 3:450.51-1 is needed by akmod-nvidia-3:450.51-2.fc33.x86_64
I have NVIDIA-Linux-x86_64-450.51.run*
but it will not run, giving the errors I’ve posted previously. So is this something I might be capable of making work? Thanks.

Hi all, thanks for reporting this issue.
This bug has been fixed. It will be available in the upcoming driver release.

1 Like

Many Thanks. Just ran
/f/Downloads/NVIDIA-Linux-x86_64-450.57.run --kernel-source-path=/usr/src/kernels/5.8.0-0.rc4.20200709git0bddd227f3dc.1.vanilla.1.fc32.x86_64/

And for the first time in months I have a working system with a current kernel. Note for others, the “path=” part should point to your current kernel. (And this displays with linebreaks where you should not have spaces.)

Hi guys, do you if its a version for Ubuntu?

@gilvbp You could probably apply the patch to the driver source (in /usr/src/nvidia*, I believe), but I’m not sure about that. For now though you’re probably better off waiting for an official release.

@samantas5855 You should mark the thread as solved, since, as of 450.57, this problem has been fixed.

1 Like