Linux Mint 19. Black screen boot.

I use Linux Mint 19 on my laptop HP Omen. I can not boot system in normal mode. I get black boot screen. I do not see even login form.
Problems started with installing drivers version 390 month ago. I was waiting for an error to be fixed in the update. But after updating nothing changes.
I reinstalled the entire system, but it did not help.
nvidia-bug-report.log.gz (63.7 KB)

You have kernel parameter ‘nomodeset’ set, remove that.
Furthermore, the nvidia module seems to be blacklisted, did you install bumblebee? Otherwise, look if any file in /etc/modprobe.d has a blacklist entry for nvidia, remove that and run sudo update-initramfs -u afterwards.

I add “nomodeset” parameter before booting system, because this is one way to avoid hovering for me now.
I did not install bumblebee.
My /etc/modprobe.d is clear. I run sudo update-initramfs -u command and restart system.
This did not produce result. I see logo of Linux Mint and then system hangs with a black screen.
I run in recovery mode now.
nvidia-bug-report.log.gz (63.3 KB)

When doing a normal boot and the issue starts, can you switch to VT using CTRL+Alt+F1? If not, install openssh-server, then do a normal boot and login from another system or smartphone using ssh. Run then to catch the error.

Do I need to install bumblebee and bumblebee-nvidia?

No, don’t install that. Forget about that, you have secure boot enabled, so the nvidia-driver doesn’t load. Disable secure boot in bios and try again.

I disable secure boot in bios and now I can not start system even in recovery mode.
I switch to VT and run with disabled secure boot.
nvidia-bug-report.log.gz (93.8 KB)

Everything looks fine now, except you created a /etc/X11/xorg.conf. Delete that, reboot, should work then.

It works now. Thanks. But I can not change screen size, i can choose 1920x1080 only. And I can not connect second monitor by HDMI.
nvidia-bug-report.log.gz (113 KB)

The nvidia driver is fine but now the modesetting driver for the intel gpu freaks out. As a temporary workaround, please create a file

Section "Module"
  Disable "glamoregl"

and reboot.

Done. It did not help.
nvidia-bug-report.log.gz (106 KB)

Now that’s some really strange Xserver bug. The file to disable glamor is accepted:

[     6.269] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.

Despite saying so, it then loads it:

[     6.623] (II) Loading sub module "glamoregl"
[     6.623] (II) LoadModule: "glamoregl"

For a hard workaround, please delete the file /etc/X11/xorg.conf.d/00-avoid-glamor.conf
and use this as /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"

Section "Monitor"
    Identifier     "Monitor0"
    Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync
    Modeline "1152x648_60.00" 59.91 1152 1200 1320 1488 648 649 652 671 -HSync +Vsync

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "none"
    BusID          "PCI:0:2:0"

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    SubSection     "Display"
        Virtual     1920 1080

Yes, now I can change screen size, but it looks like crutch (workaround).
I can not yet still connect the second monitor.

What should I do next to solve my problem completely without temporary solutions?
nvidia-bug-report.log.gz (111 KB)

The modesetting driver is still not working properly. Since this an xserver/modesetting driver bug, only way is to upgrade/downgrade the xorg graphics stack to 1.20 or 1.19.5.
You should report that to your distro.

Ok, one last idea: Check if you have a concurrent Wayland session, running, e.g. from the login manager. That could cause those strange failures of the modesetting driver.

How can I check this?

Check for processes or journal entries
ps a |grep -i wayland
sudo journalctl -b0 --no-pager |grep -i wayland

Command returns empty result

No luck then. What kind of connector are you using to connect the external monitor, btw? Was any of your logs created while the external monitor was connected?

I use HDMI connector.
nvidia-bug-report.log.gz (79.5 KB)