Linux Mint 20.2 not recognizing NVIDIA GTX 660ti even with drivers installed

Link to the unix stackexchange thread: Linux Mint 20.2 not recognizing NVIDIA GTX 660ti even with drivers installed - Unix & Linux Stack Exchange

So I have a Linux Mint machine with a Ryzen 5600G CPU with integrated graphics. I just recently got a GTX 660ti from a friend, and I’m trying to set it up, and the driver seems to be loading (running nvidia-smi gives the following):

| NVIDIA-SMI 470.74       Driver Version: 470.74       CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 N/A |                  N/A |
| 30%   33C    P8    N/A /  N/A |     67MiB /  3015MiB |     N/A      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|  No running processes found                                                 |

However, a message on boot when the card is installed mentions that the system is running without video hardware acceleration, so the CPU is doing all the graphical heavy lifting without the help of its iGPU.

So it seems like it knows the card is there, it’s just not letting it do anything. Any ideas? I tried older nvidia drivers, nouveau, installing with the .run file from nvidia, even updating the kernel to 5.11, nothing has worked.

Edit: running lspci | grep -i vga outputs

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 660 Ti] (rev a1)

I’m at a total loss.

Output of inxi -Fxxz

  Kernel: 5.11.0-38-generic x86_64 bits: 64 compiler: N/A 
  Desktop: Cinnamon 5.0.6 wm: muffin dm: LightDM Distro: Linux Mint 20.2 Uma 
  base: Ubuntu 20.04 focal 
  Type: Desktop System: Gigabyte product: A520M DS3H v: N/A serial: <filter> 
  Mobo: Gigabyte model: A520M DS3H serial: <filter> 
  UEFI: American Megatrends LLC. v: F13 date: 07/08/2021 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard 
  serial: <filter> charge: 55% (should be ignored) status: Discharging 
  Topology: 6-Core model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 3 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 93425 
  Speed: 1397 MHz min/max: 1400/3900 MHz Core speeds (MHz): 1: 1409 2: 3193 
  3: 3209 4: 3220 5: 1409 6: 3162 7: 3217 8: 3249 9: 3184 10: 3219 11: 3255 
  12: 2619 
  Device-1: NVIDIA GK104 [GeForce GTX 660 Ti] vendor: 
  driver: nvidia v: 470.82.00 bus ID: 01:00.0 chip ID: 10de:1183 
  Display: x11 server: X.Org 1.20.11 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: llvmpipe (LLVM 12.0.1 256 bits) v: 4.5 Mesa 21.2.0-devel 
  compat-v: 3.1 direct render: Yes 
  Device-1: NVIDIA GK104 HDMI Audio vendor: driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e0a 
  Device-2: AMD driver: snd_hda_intel v: kernel bus ID: 06:00.1 
  chip ID: 1002:1637 
  Device-3: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 06:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.11.0-38-generic 
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: f000 
  bus ID: 04:00.0 chip ID: 8086:2526 
  IF: wlp4s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: e000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: enp5s0 state: down mac: <filter> 
  Local Storage: total: 476.94 GiB used: 129.82 GiB (27.2%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 860 PRO 512GB size: 476.94 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-1: / size: 467.96 GiB used: 129.81 GiB (27.7%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
  Processes: 293 Uptime: 1h 05m Memory: 15.52 GiB used: 2.19 GiB (14.1%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 8/9 
  Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 

nvidia-bug-report.log.gz (266.5 KB)

It looks like at some point you installed the amdgpu-pro driver which now blocks any other glx driver from being used: => /opt/amdgpu/lib/x86_64-linux-gnu/
Please uninstall it, if it still doesn’t work, please create a new nvidia-bug-report.log.