Linux multidisplay issues with GT 710

I have two Samsung displays here and both of them do support the resolution I want to use: 1600x900. The primary display is connected to my GT 710 DVI output and is working fine, but the second one connected to the VGA output is not presenting the correct resolution as shown in the first picture. In the second and third pictures, as you can see, the resolutions are properly configured and yes, I double checked the second display built in configurations. Can someone help me with this?
Also I tested the second display with my old laptop using a VGA cable and it’s working just fine

Driver version: nvidia-455.45.01-7
Kernel version: 5.9.14


Image 2
Image 3

And that’s my xrandr output:

xrandr 
Screen 0: minimum 8 x 8, current 3200 x 900, maximum 16384 x 16384
VGA-0 connected 1600x900+1600+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00 +
   1600x900      59.82* 
   1400x900      59.88  
   1368x768      59.88    59.85  
   1280x800      59.91    59.81  
   1280x720      59.86    59.74  
   1024x576      59.90    59.82  
   960x540       59.82    59.63  
   864x486       59.92    59.57  
   800x600       72.19    60.32    56.25  
   800x450       59.82  
   700x450       59.88  
   684x384       59.88    59.85  
   640x480       59.94  
   640x400       59.98    59.88  
   640x360       59.86    59.83  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.82    59.63  
   432x243       59.92    59.57  
   400x300       72.19  
   320x240       60.05  
DVI-D-0 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900      60.00*+
   1440x900      74.98    59.89  
   1280x800      59.81  
   1280x720      60.00    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I actually can’t notice anything on the photo. What’s the exact problem?

2020-12-23-113358_663x229_scrot

Ok, now I get it. Just to make sure, it isn’t just the background image that’s incorrectly scaled, i.e. you also can’t move the mouse over the black borders?
Since this is analog VGA, did you try using the monitor’s ‘auto’ button to auto-adjust scaling/position of the screen ?

Yes, tried all the configs in the monitor but didn’t work, and yes, this monitor can handle 1600x900 on the VGA port, I tested it with another computer.
The mouse pointer and the apps can move under the black borders, not over. This is very strange… maybe a driver bug?

Sound weird. Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (238.6 KB)

that’s it

The driver is complaining that it can’t read the display information (edid) from the vga connected monitor. Please check with another cable.

Man, you were right, it was a cable issue. Tried another one and it’s fixed, Thank you very much.