Linux Quadro 3DVision fails after monitor power cycle

I have a Quadro K4000 on an Ubuntu 12.04 Linux PC connected to an ASUS VG278H monitor via dual-link DVI cable. 3DVision works great. But when the monitor is power cycled or the computer sleeps and wakes 3DVision stops working.

This does not seem to be a problem with Windows OS. ZI only have this problem with Linux.

BugFile: http://www.rawbw.com/~acorn/nvbug1/nvidia-bug-report.log.gz

To reproduce:

  • Connect DVI port on QuadroK4000 directly to ASUS DVI port with dual link DVI cable.
  • Use nvidia-settings to set ASUS monitor to 1920x1080_120 (120Hz refresh)
  • Set Option "Stereo" "10" in xorg.conf file (see full file in nvidia-bug-report.log.gz)
  • Turn on monitor and set input to DVI
  • Reboot computer
  • run glxgears -stereo
  • drag the glxgears window to the ASUS monitor and put on 3DVision glasses.
  • RESULT: stereo works great! Green "3D" icon on monitor is lit indicating IR signal is being transmitted.
  • turn off monitor
  • turn on monitor
  • RESULT: I still see 2 images, but the monitor is no longer broadcasting the IR signal to the glasses so the glasses do not work. I do not see stereo. I just see 2 images. Green "3D" icon on monitor is not lit.
  • connect HDMI port to windows machine with NVIDIA card
  • switch monitor input to show HDMI input (from windows machine)
  • RESULT: stereo from windows machine works fine. Glasses work. I see stereo. Green "3D" icon on monitor is lit.
  • switch monitor input to show DVI input (from linux machine)
  • RESULT: stereo still broken. I see 2 images but glasses do not work. Green "3D" icon on monitor is not lit.

NOTE: the problem occurs when the monitor is switched off and then on without rebooting. The problem also occurs if the monitor is not turned off but the
computer goes to sleep and then wakes up. The problem also occurs if I reboot while the monitor is turned off or while the monitor is not switched to DVI input.

Once the problem occurs I cannot find any way to get stereo to work again except to reboot the computer.

-Acorn

I am running Linux on a Linux PC with a Quadro K2000 and a ASUS VG278HR monitor. I have not get the stereo to work at all and I would love to be in the same boat with you. Could you post your xorg.conf file.

Thank you.

-YZ

My (slightly working) xorg.conf file is here: http://www.rawbw.com/~acorn/example_code/nvidia_stereo/xorg.conf.txt

The trick with xorg.conf is:

Add this line to the Screen section:

Option         "Stereo" "11"

Add these lines to the end of the file:

Section "Extensions"
    Option         "Composite" "Disable"
  EndSection

You can do this automatically with

cp /etc/X11/xorg.conf /tmp
 nvidia-xconfig -c /etc/X11/xorg.conf -o /etc/X11/xorg.conf2 --stereo=11
 sudo cp /etc/X11/xorg.conf2 /etc/X11/xorg.conf

For more info: man nvidia-xconfig

Note: also set refresh rate on monitor to 120Hz (you can do this in nvidia-xsettings or nvidia-settings program, then save xorg.conf file).

Test by running:

glxgears -stereo

My (slightly working) xorg.conf file is here: http://www.rawbw.com/~acorn/example_code/nvidia_stereo/xorg.conf.txt

The trick with xorg.conf is:

Add this line to the Screen section:

Option         "Stereo" "11"

Add these lines to the end of the file:

Section "Extensions"
    Option         "Composite" "Disable"
  EndSection

You can do this automatically with

cp /etc/X11/xorg.conf /tmp
 nvidia-xconfig -c /etc/X11/xorg.conf -o /etc/X11/xorg.conf2 --stereo=11
 sudo cp /etc/X11/xorg.conf2 /etc/X11/xorg.conf

For more info: man nvidia-xconfig

Let me know if it works for you, and post any tips you discover.
-Acorn