Linux Tower pc Sleep-Resume Graphics Failures.

First-time poster here; i cannot deduce how to attach files here, hence the following text might be harder to interpret than i’d hoped, as it’s supposed to be accompanied by several explanatory pictures. Similarly whilst i know that https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/ said to also attach “nvidia-bug-report.log.gz”, but that’s tricky without an apparent means to actually attach. Here’s its contents, pasted, but as you see it’s useless:


Start of NVIDIA bug report log file. Please include this file, along
with a detailed description of your problem, when reporting a graphics
driver bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

nvidia-bug-report.sh Version: 20259422

Date: Thu May 5 18:02:00 AEST 2016
uname: Linux Z97-HD3 4.2.0-35-generic #40~14.04.1-Ubuntu SMP Fri Mar 18 16:37:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
command line flags:

Here’s my descriptive text [but the pictures would have really helped to clarify]:

Hello

For the past few YEARS i have been fighting this problem on my two Linux Mint KDE computers [one Laptop & one Tower]. I finally solved the problem on Lappy in late 2015, but so far cannot solve it on Tower. I really hope you can advise me of a solution for my Tower please.

I do not leave my computers running overnight, but nor do i fully shut them down either. Instead i prefer to Sleep them each night, & the following mornings i like to / try to Wake them from Sleep so i can resume my activities with all my previous day’s open windows, apps & docs. However i have had LOTS of problems with this.

Each time I try to wake up Tower [& also Lappy til late last year], it exhibits variable behaviour [including perfectly correct behaviour only very rarely]. This has occurred continuously for me on Mint KDE x64 17, 17.1, 17.2 & 17.3, AND with kernels ranging from 3.x up to my current 4.2.0-35, AND with Nvidia GeForce GT 610 GPU driver from 304 to my current 364.19.

(a) Sometimes, but exceptionally rarely, upon wakeup, everything is perfect [i almost die from shock]; OR -

(b) ~50% of the remaining times, the screen is either totally black, or almost totally black but with a narrow horizontal pixelated coloured band along the top, or [& this is my “favourite” (irony)] the entire screen is beautifully filled with an ever-changing kaleidoscope of “shards” of my pre-Sleep desktop [ie, comprising a dynamic pastiche of the wallpaper, any open windows, the login box, the status bar etc; geometrically-speaking it looks similar to a broken mirror, or a crazy jigsaw puzzle of dynamically changing triangles, colours, & remnants of whatever docs, apps & windows were open on my desktop when i put pc to sleep]; OR -

<<see my attached screenshot>>

© ~50% of the remaining times, the screen is mostly ok, but with restricted / discrete bands of complete pixelation in parts of the screen.

In the case of (a) i can log back in [ie, to unlock the screen] & then seamlessly resume my work. This is obviously what should always occur, but it is so rare that i hardly ever experience it, & i never count on being so lucky.

For (b), this is the kiss of death. Nothing i have ever found/tried can recover from this; every time when this is on my screen after wakeup i slump back in my chair, curse, & kill the display via Ctrl-Alt-Backspace, then log back into a new Mint KDE session, having thus lost everything [ie, open windows, docs & programs] that i’d previously arranged on & been using in my multiple KDE Desktops & KDE Activities. I hate this. Many times [though still in the minority] even Ctrl-Alt-Backspace does not work, & i have to use the REISUB “magic SysRq key” method. Sometimes, even that fails, so i have to do a hard reset of the pc.

For ©, i almost always can log back in, & almost always can resume my work. Sometimes the only screen pixelation is in the Cairo-Dock, so i kill it & relaunch it [the dock, not the session]. Less often [but still much more often than i like], part of the actual desktop wallpaper itself is obliterated by pixelation. This wouldn’t matter except that NO window [eg, Dolphin, browser, anything at all] can be used in that region [coz that part of the window is obliterated]. I can rearrange my various open windows to skirt around the “dead zone” if it’s small enough, but if it’s inconveniently large sometimes i have to abandon that particular virtual desktop for the remainder of the session [& only work on my other 8 desktops]. Interestingly, even changing KDE Activities can’t avoid this pixelation; if it was say Desktop 5 on Activity 1 that was blighted, then that same Desktop is also blighted in Activity 2, & 3.

The above scenarios are my daily reality for Tower, & were also that way on Lappy, til i solved it in late last year. I made a major breakthrough by discovering then invoking the fundamental change in Lappy’s Nvidia X Server settings applet. Specifically by following the procedure in the following links, i changed Lappy’s settings FROM using the Nvidia GPU, TO using the embedded Intel GPU. Ever since the night i did this, Lappy’s Sleep-Resume behaviour has been PERFECT.

http://ubuntuforums.org/showthread.php?t=2221392
https://forums.linuxmint.com/viewtopic.php?f=208&start=20&t=172826
http://www.pcworld.com/article/2944964/how-to-use-nvidia-optimus-to-switch-active-gpus-and-save-power-on-linux-laptops.html
https://askubuntu.com/questions/412452/getting-hybrid-graphics-to-work-nvidia-prime-gt650m

Since that success, i have tried many times to replicate on Tower, but without success. Though i have installed the same Nvidia-Prime program on Tower as Lappy, it consistently NEVER gives me the proper choice of Intel or Nvidia; it ONLY lists Nvidia information. Many times i have inspected Tower’s BIOS config in case somehow the Intel GPU was disabled there, but i’ve never found any relevant setting.

The following internet-sourced pic shows what SHOULD appear; the PRIME Profiles option should be visible. Compare this generic pic to my ones further below; my Lappy DOES show it [hence i could fix the problem], but Tower does NOT [hence i have never been able to fix the Resume graphics problem by switching from Nvidia to Intel].

<>

My computers’ technical info:

TOWER:

Graphics: 

    Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID:00:02.0
    Card-2: NVIDIA GF119 [GeForce GT 610] bus-ID: 01:00.0
    Display Server: X.Org 1.15.1 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau)
    Resolution: 1920x1080@60.0hz
    GLX Renderer: GeForce GT 610/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 364.15 Direct Rendering: Yes

Specs:   [shows that supposedly BOTH graphics cards ARE present]:

        <<see my attached screenshot>>

NVidia X Server Settings:   [no mention of "PRIME Profiles", or Intel GPU]:

        <<see my attached screenshot>>

LAPTOP:

Graphics: 

    Card-1: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
    Card-2: NVIDIA GF108M [GeForce GT 420M] bus-ID: 02:00.0
    Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa)
    Resolution: 1366x768@60.0hz
    GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 10.1.3 Direct Rendering: Yes

Specs:   [also shows that both graphics cards are present]: 

   <<see my attached screenshot>>

NVidia X Server Settings:   [DOES show "PRIME Profiles", & DOES allow me to choose either Nvidia or Intel GPU; with NVIDIA selected, all the bad Sleep-Resume graphics problems occurred; with Intel selected, Resume is perfect]:

   <<see my attached screenshot>>

BOTH COMPUTERS:

   <<see my attached screenshot [shows that "nvidia-prime" (& applet) IS installed]>>

Any suggestions please? Ideally i’d like to continue using the Tower’s NVidia card AND have Sleep-Resume work correctly, OR, be able to use NVidia-Prime & switch to the Intel card.

Nobody? Anybody?

Could someone at least please help me to understand how to upload pictures? These might substantially help readers to understand my problem better.

Notwithstanding the overwhelming level of support received here, i’m happy to report for posterity that my problem is now solved, in case this info might help others. See https://devtalk.nvidia.com/default/topic/581510/black-screen-on-resume-from-suspend-with-325-15-and-kwin-4-11-with-enabled-compositing/?offset=9#4885132