List of Tested WiFi Adapters

I have been struggling to find a WiFi adapter that works well with the TK1. I purchased my third wifi adapter this week and I hope for better luck (my wallet does as well). I thought this would be a good place for people to list the adapters they have tested and the results of their findings.

Adapter: Intel 7260 mPCIE
Kernel: Grinch 19.3.3
Result: Most of the time will not connect; when connected, will disconnect after a few minutes; signal strength very weak
Notes: Tried the following (per https://devtalk.nvidia.com/default/topic/767615/embedded-systems/intel-wifi-adaptor-jetson/)
Placed:
options iwlwifi 11n_disable=1 power_level=5
into /etc/modprobe.d/iwlwifi.conf

Adapter: Atheros PCIe Card BGN AR5BHB92 AR9280
Kernel: Grinch 19.3.5
Driver: ath9k
Result: I was able to connect a couple of times and keep connection; most of the time cannot connect; signal strength very weak
Notes: Tried the following
Placed:
echo “options ath9k nohwcrypt=1” | sudo tee /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k

     also tried:
     iwconfig wlan0 power off

I can confirm TL-WN723N (RTL8188EU) usb wifi adapter works well with Grinch 19.3.5

Forum is good for discussions and wiki is good for storing information: http://elinux.org/Jetson/Network_Adapters

Hi, I will try backport newest driver for you

I would agree, except that the list is inaccurate/misleading. Let me preface that I sincerely appreciate the work of Santyago who has been a tremendous help. There are several instances on this forum that have pointed out that chipsets, like the Intel 7260, do not work, at least in a reliable sense. This thread was conceived as a discussion of what people have tested, what they found to work (or not work), what they have tried and what other experiments should occur.

I have an Intel 7260 hmw. You must install the appropriate firmware into /lib/firmware. Firmware located at:

http://wireless.kernel.org/en/users/Drivers/iwlwifi

It works for me using the grinch kernel, with attached antennas, with the following in my /etc/rc.local:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 191 > /sys/class/gpio/export;
echo out > /sys/class/gpio/gpio191/direction;
echo 1 > /sys/class/gpio/gpio191/value;
modprobe -r iwlwifi;
modprobe iwlwifi;

exit 0

I have not experienced flaky connections as of yet. Do you have antennas? Without connecting antennas, my card would not detect APs. Antennas are a must for Intel 7260 HMW.

I suspect that a kernel I compiled myself might have worked had I known about the gpio business earlier. It would take me too many hours to test that theory though, so I’m sticking with grinch for now.

Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01) With Bluetooth Works great.

Haven’t been able to get Broadcom BCM4352 working at all. Appears to be unsupported.

*-network UNCLAIMED
description: Network controller
product: BCM4352 802.11ac Wireless Network Adapter
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0
resources: memory:32400000-32407fff memory:32200000-323fffff

L4T R21.3 is out, you may wish to flash this for various fixes, including network.

Before doing so, understand that many drivers simply are not installed by default on small embedded systems (imagine your smart phone arriving with every driver your desktop system has available). Once the drivers are in place, the wireless will still fail until other packages are installed and/or configured (don’t ask me which, I’m not a “wireless” guy…typically there are firmware files which go with the driver). There are all kinds of Broadcom modules which could be added and might do the job. On an R19.3 I see this from the /proc/config.gz:

gunzip < /proc/config.gz | egrep -i '(broadcom|bcm43|brcmfmac)'
# CONFIG_BCM4329_RFKILL is not set
CONFIG_NET_VENDOR_BROADCOM=y
# CONFIG_BROADCOM_PHY is not set
# CONFIG_BRCMFMAC is not set
# Broadcom specific AMBA

In the above output there is a possibility that any of those commented out and unset kernel configuration options could solve the driver side of the issue. I just can’t guarantee it, but the BCM4352 may work as part of the BCM43xx family. Also, I don’t see any output from ifconfig or iwconfig…if either of these detect the card then you have a driver in place but nothing configuring it.

Hi,
with Intel 7260 HMW and an external antenna I can connect, but pinging the router from my jetson gives 200-300ms (very unstable).

The only hint that I have to debug this problem is that the Tx-power given by running iwconfig is 0dBm and I did not manage to increase it. How does it compare with your iwconfig output?

I’m running the grinch 21.2.1.

Just got a BCM 4321 running great. Been as solid as a wired connection for over a day now. It’s an older card and doesn’t have Bluetooth, but connects reliably at about 54 Mb/s.

Of course, it’s twice the height of newer cards, so there is no way to screw it down to the board. It actually is made to mount to it’s own pci card, which plugs into a pci slot. But, if you need wireless, and have one of these lying around like I did, it works well, and is easy to set up.

For me Jetpack 2 Kernel 2.4 self compiled when needed.

AR9285 Atheros ath9k (bought over Amazon)

Connects even without antennas, but system then fails to reboot or halt (stops with a kernel error)

RTL8187SE Realtek r8187se (taken from an ASUS Netbook)

Fails as kernel does not have drivers in it. Tried some drivers no luck.

7260 HMW Intel iwlwifi (bought new from Amazon)

Works out of the box, with or without antennas

Bluetooth is patchy but I don’t need it.

Using a TP-Link Wifi Extender and using a cat 7 from said wifi extender does a mock up wifi card very well :)

RTL8188CUS Realtek rtl8192cu (Laying around bought ages ago)

works right out of the box

Bought an RTL8812AU USB Dongle from Asus, works good with asus drivers after compiling them.

NOTE: “patched driver” on the Wiki DOES NOT WORK. Please update it. I added instructions here:
https://devtalk.nvidia.com/default/topic/924070/linux/cross-compile-driver-for-asus-usb-ac56-/post/4837683/#4837683

Trying to connect intel 8260 using M2 to mini PCIe converter, tried backporting with the latest stable driver and few others but no luck so far. My network is unclaimed according to lshw -C network.

Tried latest stable backports-4.4.2-1 driver https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v4.4.2/
and then backports-20150923 driver according to this post http://askubuntu.com/questions/697279/installing-intel-iwlwifi-firmware-for-unclaimed-wireless-8260.

Also tried this backport driver for iwlwifi which does not compile https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/backport-iwlwifi.git/

I have also downloaded correct firmware iwlwifi-8000C-13.code.

Has any one tried to connect intel 8260 to Tegra K1? Any support will be appreciated!

Hi Running Ubuntu 16.04 LTS on Jetson TX1 and wondering if I can get the Azurewave (Broadcom) BCM94352HMB 802.11AC card to work. Is it detected on lshw:
*-network UNCLAIMED
description: Network controller
product: BCM4352 802.11ac Wireless Network Adapter
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:01:00.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: memory:13200000-13207fff memory:13000000-131fffff
However, I have not found a resource to make it work. I have seen other people messing with Kernels and such, but that is over my head. Is there a method I can use to make this card work?

Thanks