Llvmpipe instead of nvidia GTX 1650

I want to use my dedicated GPU for gazebo and rviz simulations but so far my integrated gpu is being used.
What I did:

  1. Disabled secure boot
  2. Installed ubuntu 18.04.6 with nomoset in grub
  3. Installed nvidia drivers from ubuntu additional drivers

My nvidia Xserver settings know that I have GTX 1650 but in additional drivers it shows NVIDIA corporation unknown hardware

My friends and I am getting 5-10 fps in gazebo and many more people in the community are also experiencing the same issue but there is no concise solution.

Specs
AMD Ryzen 5 4600H with Radeon Graphics 3.00 GHz
nVIDIA Geforce GTX 1650
8GB RAM
HP Pavillion gaming laptop
ROS melodic
Ubuntu 18.04.6

Hi!

I assume the post here: Ubuntu 20.04 using llvmpipe rather than Nvidia Driver
is related, could it fix your issue?

I could not🥲

Of course, I didn’t check closely enough. Would it be ok if we merged your request from here with that topic in the public forums? That way we can get more exposure and hopefully help you better.

Yeah why not☺️

1 Like

Since the only common thing is the mention of “Llvmpipe” in the topic title, I think merging is not necessary.

But the other topic has some good starting points to help you debug your issue @naitik.singh.phe20.

Could you please check the output of nvidia-smi and also try to chose NVIDIA as the main GPU by using prime-select?

prime-select query
will show which card is being used while
sudo prime-select nvidia
should chose the NVIDIA GPU.

If that still does not solve your problem, please read this post first and then attach your nvidia-bug-report.log.gz here.

And welcome to the NVIDIA developer forums!

Many of your ros/gazebo community members already showed up here.
Problem: 18.04 kernel doesn’t support your ryzen 4xxx gpu so you will need to install a kernel manually:
You will need 4 packages
linux-headers-XX
linux-headers-XX-generic
linux-image-unsigned-XX-generic
linux-modules-XX-generic
from Index of /~kernel-ppa/mainline/v5.10.79
and remove the ‘nomodeset’ kernel parameter.
Though you might run into problems with the gcc version. If all runs well, you’ll have to tinker a bit with xorg config:
nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings - NVIDIA Developer Forums

I am not able to update to new kernel as it requires libc6 version 2.33 which is not available for ubuntu 18.04

Please try this ppa:
https://launchpad.net/~damentz/+archive/ubuntu/liquorix
It has a 5.15 kernel for 18.04