lmgrd broken in 12.8?


I’m having trouble starting the license manager binaries included in 12.8 being called lmgrd. If I try to start it even from the command line I get:

reuti@erwin:~> /opt/pgi/linux86-64/12.8/bin/lmgrd
-bash: /opt/pgi/linux86-64/12.8/bin/lmgrd: No such file or directory
reuti@erwin:~> file /opt/pgi/linux86-64/12.8/bin/lmgrd
/opt/pgi/linux86-64/12.8/bin/lmgrd: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), stripped
reuti@erwin:~> ldd /opt/pgi/linux86-64/12.8/bin/lmgrd
/usr/bin/ldd: line 116: /opt/pgi/linux86-64/12.8/bin/lmgrd: No such file or directory
reuti@erwin:~> readelf -d /opt/pgi/linux86-64/12.8/bin/lmgrd 

Dynamic section at offset 0x148028 contains 24 entries:
  Tag        Type                         Name/Value
 0x0000000000000001 (NEEDED)             Shared library: [libpthread.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libm.so.6]
 0x0000000000000001 (NEEDED)             Shared library: [libgcc_s.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.6]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.2]

I tried it on 32 bit too with the same result.

I remember, that I got this when I tried to link a shared binary but only supplying *.a files, or static binary with dynamic libs (I don’t recall excatly). This seems to happen to license manager tools since 12.1.

Going back to 11.8 all is fine (despite that I can’t use any compiler from the 12.* series). I tried on openSUSE 11.1 and 12.1 with the same results.

How can I get access to the 12.x series (and yes: I have a valid license token).

Hi Reuti,

Newer FlexLM license mangers (lmgrd) have adopted the “Linux Standard Base” (LSB) standard (see: Linux Standard Base - Wikipedia). However, not all Linux OS yet install LSB by default. Please install LSB.

While I’m not positive of the commands to install LSB on openSuse, I believe you’ll need to run “rpm -q lsb” and “rpm -q lsb-release”.

Hope this helps,

Hi Mat,

Oh yes - thx, this could have spotted my eyes earlier as it’s of course also noted as necessary interpreter in the program headers section of the readelf output. The first software I got where this is necessary though. I’m still unsure what advantages are offered by using a different interpreter.

Especially as is creates the effect, that many dependences are shown on a text only server installation during installation to get a complete LSB installation incl. a bunch of X11 stuff. Hence I didn’t use YaST/zypper to install it, but downloaded the necessary package and used:

rpm -i --nodeps ~reuti/lsb-3.2-1.38.x86_64.rpm

Then it will install only the program interpreter and some additional files. For now this seems to be sufficient.

As this was the first time I encountered this, I get the impression that LSB isn’t in widespread use. I’m curious why Flexera moved to it.

– Reuti