login-loop on tx2

Hi,
I’m having a login loop with a jetson tx2 running the jetpack 3.1.

I have tried the following solutions (without success) found on devtalk and other forum:

  • dpkg-reconfigure lightdm
  • reinstall lightdm
  • delete .Xauthority from the user home
  • add a new sudo-user

The command ‘sha1sum -c /etc/nv_tegra_release’ shows that everything is ok.

The software configuration is the one coming with jetpack3.1, plus opencv3 and pcl libraries built from sources.

The day before this happens I left the jetson running and after a while I come back and I did find it turned off.
I press the power button and it boot without errors. Could it be connected to the login-loop error?
In the same day I also have installed ‘libsdl2-dev’ using apt.

Can anyone help me?

Thank you

Check also that user belongs to group video.

Thanks for the quick reply!

yes, it belongs to video group

Thank you

Using serial console or ssh you might want to run “dmesg --follow” and see if something prints during a failed login attempt. In a similar way you may want to run “sudo tail -f /var/log/Xorg.0.log” and see what shows up during the login attempt.

Thank you linuxdev!
I’m not so skilled to know what’s happening.
I have attached 2 photo of the output of the two commands.

Thanks

IMG_20180221_093655.jpg
IMG_20180221_093606.jpg

IMG_20180221_093655.jpg

IMG_20180221_093606.jpg

This is indeed a bit odd. I say that because the messages might be expected in normal operation when someone logs in and back out. The 1920x1080 mode should be valid. My thought is that because the login prompt shows up it isn’t the login manager. Because lightdm itself was being manipulated, I highly suspect it is merely some configuration related to this causing its spawn to immediately be terminated due to configuration and not due to any crashed application.

Sometimes re-installing does not also reinstall items related to configuration. If you were to reinstall lightdm and it still fails I think it would narrow it down to configuration files. See if this changes anything:

apt-get install --reinstall lightdm

If at some point you see any option related to configuration files being backed up carefully write down and note the name of the file. Any next step would probably be to examine those files…it no such file is mentioned more research might be in order for lightdm init.

I would also check if after pressing Cntrl+Alt+ F2 it will login fine to the terminal mode without GUI. When you are in the text mode and logged in

df -h

will show if you have disk space available.

I used to get “login-loop” having zero disk space.

If nothing helps you may reinstall the OS via Jetpack.

Hi,

@linuxdev
-> reinstalling lightdm no config files are being backed up

@Andrey1984
->

nvidia@tegra-ubuntu:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        28G   22G  4.2G  84% /
devtmpfs        7.7G     0  7.7G   0% /dev
tmpfs           7.7G  276K  7.7G   1% /dev/shm
tmpfs           7.7G   22M  7.7G   1% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           7.7G     0  7.7G   0% /sys/fs/cgroup
tmpfs           786M   20K  786M   1% /run/user/1001
tmpfs           786M   36K  786M   1% /run/user/106

Thank you!

It seems to have enough space available. Moreover, it seems to log in to the text mode successfully.
As I understand if you execute from the text mode

sudo init 5

or

startx

it will throw up a loop login.
I would try

apt-get update
apt-get upgrade

possibly would install additional gdm like

sudo apt-get install openbox obconf

if nothing helps I would reflash the jetson.

I’d have to agree with @Andrey1984…it may actually be simpler flashing again even if it seems drastic. You could clone first if you are worried about losing something in the software.

Thank you!
I’m going to reflash the TX2…

FYI: I have installed openbox as suggested by @Andrey1984 and it lets me login while gnome is still with the login-loop

The issue seems to be Unity specific.
Since openbox doesn’t use the Unity it works.