Login loop with Ubuntu 16.04 with Nvidia GTX 1060

Good afternoon everybody,

I am the owner of a notebook made by MSI (model GS63VR 7RF) with a dual boot setup with Windows 10 and Ubuntu 16.04 LTS. Secure boot and fast boot are disabled. Until yesterday, both OS were working fine.

Now when I try to boot on Ubuntu, the login screen loops every time I am asked for my password and do “enter”.
After looking online, it seems that this problem is linked to the GPU, and that it happened after an automatic update from version 375 of the Nvidia driver to the version 384.

I can boot in graphics safe mode and open a terminal. I have tried to purge the drivers and switch back to version 375 (following this forum link) but it did not change anything. I also tried to switch to the Intel-integrated GPU with “sudo prime-select intel” but this makes the problem even worse as I cannot even see a login screen.

Could my problem be due to the fact that I am using the 16.04 LTS version of Ubuntu and not the 17.04?

Is a sudo apt-get purge nvidia*, autoclean, autoremove nvidia*, add-apt-repository ppa:graphics-drivers/ppa, update, autoinstall, reboot the best way to install the driver for Nvidia? Is the latest one really recommended like it is written?

Many thanks in advance for any help and I would be happy to provide further tests/benchmark.

Install the nvidia driver package, then run
nvidia-bug-report.sh
and attach the tar.gz file it creates your post.
In the package case, it’s
/usr/lib/nvidia-XXX/bin/nvidia-bug-report.sh
with XXX being the version of the driver

Hi generix, here is the attached log: http://www23.zippyshare.com/v/dYCFefj0/file.html

It has nothing to do with nvidia, you somehow broke your intel kernel driver. Since this is a skylake platform, it needs extra firmware. Do a system update and see if the package linux-firmware is installed or reinstall it. Also check/reinstall the packages linux-image-XXXX-generic and linux-image-extra-XXXX-generic with XXXX being the kernel version. Especially the ‘extra’ package, it contains the intel driver.

Hi @generix, thank you for this suggestion but unfortunately it did not work either. I also tried a fresh install of Ubuntu and tried to install manually the Nvidia driver without success.
If I have a fresh Ubuntu, what do you recommend to correctly install the drivers? Update the intel GPU driver first (with its firmware) and then the Nvidia driver? With the ubuntu repository or from the Nvidia website? Would it change anything?

Thanks for your support

You will first have to have a plain intel system working. Since this an optimus system, the nvidia gpu depends on that. So forget about the nvidia driver until that works.

If you think you have the intel system working, post a Xorg.0.log and a dmesg output.

Ok. Besides that, would you have an opinion about the option of using Ubuntu 17.04 instead of the 16.04 LTS regarding hardware handing and stability?

16.04.3 should be fine regarding hardware stack. Kernel 4.10 and xorg 1.19.3 is pretty much up-to-date. 17.04/10 only makes sense if you want the latest desktop/user software.

I am also facing similar issues.
I had my alienware with kabylake nvidia gtx 1060 working fine with both prime and bumblebee to swich between integrated/dedicated graphics until nvidia-384 update i assume( Nvidia persistence demon stops working in every startup sessions and I was forced to reinstall ubuntu and now not even the prime setup works properly. I can boot prime good only if while rebooting I switch the grub with nogpumanager.
still while loading intel nvidia persistence demon is not working.

Here is the bug report.

abramjos, you should have opened a new thread for this.
The log is basically useless, it just shows that you’re running on plain intel now. Please remove nogpumanager from kernel parameters, run prime-select nvidia, reboot and then run nvidia-bug-report.sh again.