Logo Customization

I’m trying to perform logo customization as given in
https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/Bootloader/UEFI.html#customized-logo

then i tried to build it using

i have a ubuntu 20.04 system
i cant run this following command
sudo apt-get update
sudo apt-get install build-essential uuid-dev git gcc-12 g+±12 python3
virtualenv g+±12-aarch64-linux-gnu gcc-12-aarch64-linux-gnu
device-tree-compiler mono-devel lcov
as gcc-12 is not available on ubuntu 20

still i just tried proceeding by installing rest of the packages and then
when i executed this command in pc

edk2-nvidia/Platform/NVIDIA/Jetson/build.sh

i got the following error
nvidia: building from workspace rooted at: /home/inbe1e-dt550cn/CNHi/AGX_ORIN/LOGO/edkrepo/nvidia-uefi
nvidia: found command: python3.
nvidia: found command: virtualenv.
nvidia: found command: mono.
nvidia: found command: aarch64-linux-gnu-gcc.
nvidia: found Python 3.10 or later.
nvidia: Creating Python virtual environment in /home/inbe1e-dt550cn/CNHi/AGX_ORIN/LOGO/edkrepo/nvidia-uefi/venv…
Traceback (most recent call last):
File “/usr/bin/virtualenv”, line 6, in
from pkg_resources import load_entry_point
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 3254, in
def _initialize_master_working_set():
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 3237, in _call_aside
f(*args, **kwargs)
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 3266, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 584, in _build_master
ws.require(requires)
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 901, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 787, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The ‘importlib-resources<2,>=1.0’ distribution was not found and is required by virtualenv

Hi srivathsan.p,

So, it seems the build environment issue.

Could you also try with Build with docker?

i’ll give it a try