Lost access to all USB ports, including type C, after upgraded from Jetpack 4.4 to 4.4.1

Was trying to pick up some bug fixes for Jetpack 4.4, I was able to use the Type C USB to reflash the AGX Xavier from Host CPU successfully, but the AGX
Xavier stuck s on the “L4T … license agreement” screen after reboot. Since we cannot use any of the USB ports t for the keyboard and mouse to click the “Agree” check box to proceed to the next page.

Also tried to downgrade it to JetPack 4.4 and 4.3, the issue still persists.

I don’t know the original cause of the problem, but flash should have made it possible to go back. Does this use a third party carrier board, or is it a dev kit? If third party, then you’d need their firmware (mostly a device tree).

If this is a dev kit, then serial console should still work. Have you tried serial console?

It is a 3rd party product, we do have 2 serial consoles come with it.
I thought flash should reverse this, but it did not.
Will give it a try with the serial console port.


Do be careful to use the third party’s device tree or other firmware for the flash. If this is not used, then losing USB would be expected (assuming this carrier board routes differently than the dev kit carrier, which is likely).

Serial console may change as well, but if you see serial console output during boot, then it probably works.