Low performance in DOOM Eternal

Maybe some round-up of the known infos of this bug:
AFAIK, Doom Eternal uses (slow) system memory instead of vmem when run on nvidia.
So Nvidia did this:

2020-04-07 version 440.82
    * Added a workaround for Steam Play title DOOM Eternal, which overrides
      application requested memory locations, to ensure performance-critical
      resources be placed in video memory.

Some versions later, this showed up:

2020-09-17 version 455.23.04
    * Added support for a new device-local VkMemoryType which is host-coherent
      and host-visible. This may result in improved performance in some
      applications. Applications which are known to benefit from this new
      VkMemoryType include: DXVK Title DiRT Rally 2.0, Steam Play Title
      DOOM: Eternal, and DXVK title World of Warcraft.

IDK, but the latter one looks to me like this has to be implemented in the application, in this case dxvk/vk3d (whichever one Doom uses, or does it use vulkan directly?)
So maybe the workaround was v440 exclusive?

1 Like

That is native Vulkan.

So maybe the workaround was v440 exclusive?

Not possible. That workaround will always be needed unless app side fixes it’s behaviour.

1 Like

Yes, feared so. Though rather puzzles me why this is only happening with the Linux driver and not on Windows, if Doom’s using Vulkan natively.

1 Like

i almost finished downloading doom 2016 but i decided to look at what Vulkanguy pointed out
and doom eternal report 4342MB of vram so there is a problem there

i have the same bug on doom 2016 exept that it runs at 1-20fps
BUT it use way more vram still report the wrong number and is unplayable

Clearly there is something wrong with GTX 1050 4 GB Mobile but since @amrits tries to repro with a GTX 1650 he is not able to repro.

1 Like

i found something interesting in doom 2016 if i switch to nvidia only (disable offload) i get adequate frame rate, but the vram still display wrong so i don’t think this isn’t the issue.

but doom eternal is still unplayable
i tried to uninstall lib32-vulkan-intel and vulkan-intel from my system but no changes.

i just noticed that dmesg report
nvidiafb: unknown NV_ARCH

nvidiafb should be blacklisted when the nvidia driver is installed.

1 Like

thanks i no longer have the error but no luck for the game tho

Having the same issue on my RTX 2060 max-q. Using the nvidia 460.39-6 driver.

Yep there definitely is a problem, I mentioned that it was still an issue months ago:

2080 Super Max-Q here

the is not improvement with the lastest driver 460.56

I too am having this issue on 460.56 on a 2070 Super. Reverting to 450.106 changes nothing. So this definitely came earlier. This is with & without steam overlay. Everything attempted so far:

  • Different kernel versions (5.8 & 5.11)
  • Different Proton versions (5.0, 5.13, GE 5.9 & 6.1)
  • Different drivers (450 & 460)
  • Various nvidia settings
  • Various game settings
  • Steam overlay on/off

nvidia-smi shows the ~850MB usage (by Doom Eternal) others are seeing. System monitor shows ~2GB usage while the game thinks it’s using 6GB of VRAM with all settings maxed.

And you are on a desktop system or Optimus?

Desktop, no other card.

I have filed a bug 200713923 internally for tracking purpose.
Will keep updated on it, Thanks.

1 Like

Mostly crossposting back here for better visibility since I saw the link to the other thread and the advice there helped. Apologies if it’s bad practice around these parts.

The idea of setting __GLX_VENDOR_LIBRARY_NAME=bla in launch options instead of nvidia from VulkanGuy’s post here has resolved the VRAM issue for me on my desktop.

1 Like

This issue is fixed in the newly launched 470.42.01 Beta.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.