Low rendering resolution on RTX 3060 laptop

Presently View is limiting rendering to 1,272 x 650 pixels when linked to SketchUp… my RTX 3060 has 6 GB VRAM. Any methods for increasing the resolution, such as using cloud-based resources?

Hi Nicholas,
I am pretty confident in saying that View is not technically limited to any resolution. I have it set to 4k most of the time. It is however massively dependent on video memory. A 3060 is really our absolute minimum specs. However, again, it is not limited to 1272x650. Can you describe the exact issue that you are having? In the bottom right hand corner you will see a resolution menu. By default it is set to “Fill” which just fills the pixels of the UI window. If you want to go higher you can maximize the View App, or you can uncheck “Fill” and select one of the Presets. For example 720p,1080p, 2160p. You can even enter a Custom resolution for anything you want. If this is not the case, please let me know.

Also you said “when linked to Sketchup”. Not sure how that would affect it. Does View go higher for you when ‘not’ linked to Sketchup ?

Now, keep in mind that my comments reflect limited experience with Omniverse, although we do have decades of work in the computer graphics and rendering area.

  1. In SketchUp, the file is converted to USD by pressing the NVIDIA icon
  2. Omniverse View opens up (the process takes a couple of minutes)
  3. Selecting presets such as 2160P for example causes the vRAM in the GPU to be exceeded, and View changes the resolution to 1485 to 783.
  4. If I selected 1440p, or 1080p, the UI shows 1.1 GB available, but again, after a moment, the resolution changes to 1485 x 783.
  5. Opening the Settings panel reduces the display port to 1041 x 783. Closing Settings returns it to 1485.
  6. So basically my model consumes about 5 GB VRAM and at the moment, it isn’t possible to get View to go higher than the resolutions indicated, which is way too low for our purposes.

My computer is a Dell XPS 17 9710 laptop, 32 GB, and the Windows desktop is extended to a separate 2K monitor, in addition to the 4K monitor on the laptop.
7. On the 4K monitor, View allows 1528 x 888.
8. Performance is the same, if connected to SketchUp or not.

So that’s where we are right now. Please let me know what to try next…


Thanks so much for the personal reply; we are highly enthusiastic about Omniverse, and in the broader picture, plan to use it for developing several healthcare-related digital twins. Renee Yao at the Inception program is aware of our work and is always providing encouragement. My apologies for the delay in getting back to you, but over the weekend, we got a cloud instance of Omniverse set upon in AWS, per the video from Drew Como https://www.youtube.com/watch?v=TWCKzi2_MAI&t=206s. We’re trying to build up our competence. 😊

Now, keep in mind that my comments reflect limited experience with Omniverse, although we do have decades of work in the computer graphics and rendering area.

Thanks for your reply. Yes it sounds like you are doing some exciting work and exploring Omniverse. My comments are purely technical so I understand your computer graphics experience. If indeed you are seeing an active denial from view where it is reverting you back, that would be a first for me. However I have not see it work directly from sketchup. It is possible that sketchup itself is driving the resolution.

You say that you have tried running the file directly in View, without Sketchup. Can you try two things.

  1. If possible can you take a video recording of your screen, so we can see this behavior live.
  2. Can you try opening the file in Create and see if this also has a strange issue with resolution.

And you are sure FILL is set OFF on the resolution menu ?

Hi! Thanks for the suggestions. Let me try them out in the morning. BTW I think you mean …FILL is set OFF… let me check.

Now, with only 6 GB of vRAM, doesn’t this limit the size of USD model which can be rendered? Or does the RTX work in pieces of the model and then assemble them at the end?

The ray tracing certainly looks convincing, it’s just the resolution is way too low for the moment. 😀😀

SocialEyes Corporation
WhatsApp +977 98 2332 8602
GMT +5:45

OK I am re-reading the thread and I’m working on a theory. You have a laptop with a very high resolution screen 4K. I bet you have scaling on because most laptops set up for 4K have at least 250% scaling. What I want you to try is to put the scaling back to 100%, see if that makes a difference. Also, try a lower resolution like standard 1920×1080. Again at 100% scaling.

Secondly, can you disconnect exterior monitor? The reason we are doing this is to see exactly what is triggering the strange resolution . It may be something to do with the way the windows is reporting the screen resolution to the program.

This is the key… Make sure that “Fill” is disabled…

Ok so you disabled FILL and now its ok ?

It seems like certain interactions with the UI can enable the Fill setting… just double check to make sure it’s off… should fix the issue.

Yes we are fixing that shortly

Hi Richard… We’re available for testing new versions… we are running a 4K Dell 9710 laptop, and perhaps the resolution may be contributing to some of these issues we’ve been experiencing…

We also use a second 2K monitor via HDMI and extend the desktop to it. My experience is that this combination may not function as smoothly as expected.

Yes you have two issues here. Firstly A 3060 laptop gpu is really on the very lower limits of the min specs, because of its power and memory. Secondly, you are already putting the card through a lot of strain with running your laptop display at 4k and then on top of that, adding 2k more of external monitor. So the performance you will get will be limited by all of that initial vram taken up already. If you were to disconnect the second monitor and run the laptop of 1920x1080, you will have much more speed and vram for the program.

Then, when in View, make sure FILL in set to OFF, and run the display at 720p, or 1080p

What issues are you experiencing ?

We’ll do some additional experimentation… the laptop has an Intel GPU to run the displays, so AFAIK, the 3060 should be highly available for rendering. But let me check…

Also OV doesn’t seem to understand Windows virtual desktops. If one adds OV to the taskbar of one desktop, it appears on all the desktops. :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.