M4000 Mosaic Sync w/SLI Issue

Just wanted to provide all my details on troubleshooting sli/mosaic so bear with this lengthy description:

We have experience deploying this configuration on an older ASUS chipset [x99] with these M4000 cards and have been able to deploy mosaic [with sync] with sli before.

When we first attempted this configuration, it was on the ASUS x470-pro board and an AM4, ryzen 5 1600 chip. After weeks of trying to get mosaic sync functioning, finally broke down and rebuilt the entire machine on the i7 8th gen chip instead.
All of my testing with the am4 board, 2 M4000s, and sli bridge lead me to a state where every time we would get sli functionality recognized [but not enabled] in the nvidia control panel, mosaic settings would always show “sync not supported” and we could never create a mosaic with the sli bridge in place. The machine would crash to a variety of states: windows bsod, sometimes losing all outputs but one, sometimes freezing up until the power is pulled.

We moved to the i7 board because there was more troubleshooting knowledge available across the web and other resources. At this point we have completely set aside the AM4 machine for this project and are working to get an intel machine running but running into the same issues.

Our current configuration is an intel i78700 on an ASUS Z370-a motherboard with two Quadro M4000 cards + an sli bridge. The machine feeds 7 DisplayPort to dvi outputs to a dvi switcher. The dvi switcher supplies its own edid at 1080p60. The switcher then feeds 7 projectors via HDbaseT.
The intel machine does not see the projectors only the switcher.

We are running an enterprise version of windows 10, known as long-term-service 2016, which does not received feature updates, running v1607. This is the same OS version/edition we had been managing previous sli deployments with over the last two years.
When we were unable to make any progress in our troubleshooting, we took a chance on deploying a brand new lts 2019 [released nov 13 2018] version of this long-term-service windows channel - however, it has absolutely no effect on the behavior of the sli functionality on the machine.

We are limiting our testing and troubleshooting notes to the v1607 build, on the intel machine, as previously noted.

In our testing we have worked through multiple possible issues, including:
updating the bios on the motherboard to the latest available version + checking pcie settings for x8/x8; configured in OS via GPU-z applet
using displayport1.4 to dvi adapters and confirming DisplayPort video signal in nvidia control panel
[in nvidia control panel/systemtopology/edid] saving the edid from output one and then loading the saved edid to all the outputs
tested multiple sli bridges [3] with compatible asus model numbers
attempted the configuration on a second asus z370-a motherboard
additionally, each time that we would reinstall the driver or have to repair the driver in windows 10, we would run the machine in safe mode and use [ddu] display-driver-uninstaller, an nvidia recommended utility, to remove all traces of the old driver each time
windows 10 has been set to never install drivers for hardware automatically/via the internet/updates
I have also run this procedure with drivers as old as v377 and still see the same behavior

I have tested each of the above conditions at each and every step listed below:

With both graphics card installed, and no sli bridge in place, I ran DDU in safe mode and then rebooted and installed the graphics driver.
The mosaic settings show “Sync not supported” and I can create a mosaic for our 7x1 array however there is no sync across the gpus.

If I shut down the machine and add the sli bridge, nvidia control panel will not open unless you restart the nvidia container LS service.
The tab for “PhysX + SLi Configuration” in nvidia control panel only says “physX configuration”.
The mosaic settings shows a green check mark for “Single GPU Sync” between the two M4000s, and shows all 7 displays in mosaic windows, however when proceeding with “create new mosaic config” we can only create a mosaic only with the 4 displays that are connected to the first gpu. The drop down in mosaic configuration only shows mosaics of 2, 3, or 4 displays.
If i try to reinstall the driver, without using ddu + with the sli bridge now in place, it repairs the nvidia control panel issue and missing “phyx + sli” settings, but behaves the same as noted above.

If I have the sli bridge in place and run DDU in safe mode then reboot and install the driver, the nvidia control panel, the tab for “PhysX + SLi Configuration” only says “physX configuration”.
If I reinstall the driver, without using ddu, sometimes i can get the nvidia control panel menu to correctly say “physX + sli”.
However, the mosaic windows still says that “sync is not supported” and when you try to create a mosaic the machine crashes with various different bsod messages including: SYSTEM_SERVICE_EXCEPTION, IRQL_NOT_DISPATCH_LEVEL, KMODE_EXCEPTION_NOT_HANDLED, + more.
When the system crashes, the driver is not available [nvidia control panel is gone + the devices are recognized in device manager] and only one video out will function.

In the final deployment of this machine, we maintain the content performance and updates remotely, so we will not be able to remove/re-add the sli bridge if anything goes wrong.
From my troubleshooting with nvidia, i was informed the sli bridge and both gpus should be hooked into the system at all times.

When mosaic is configured successfully, there is a second layer of software that wraps the display to corrects for effects the projection coming down at an angle. Then we run our content in a simple wrapped applet.
We know that, if we complete all the steps without the sli bridge, that everything [warp software + content] does play back correctly per design. However, the performance different between the two GPUs is visible in some light tearing and issues with the displays coming from the second card sometimes flicker.
We see both of these issues as stemming from the lack of mosaic/gpu sync. At this time we cannot use a sync card because the last pcie slot us need for a usb pcie card that supplements other features in the system.

In some bizarre cases, the “physX + sli” issues occurs outside of the above described condition, sometimes missing the “sli” settings after a reboot.

Here are some links specifying the tech we are trying to use here - none of them seems to reflect current cards on the market or feature any updates for windows 10/troubleshooting [or any info at all post-2010]:
https://www.nvidia.com/object/quadro-scalable-visualization-solutions.html
https://www.nvidia.in/object/quadro-sli-technology-in.html
our hardware does come from an approved list here: https://www.nvidia.com/object/sli-ready-motherboards.html


If anyone has ANY other recommendations for trying to get mosaic/sli configured correctly, I am open to all suggestions.