M6000 + 1080Ti Centos7 not keeping my screen resolution after each reboot

I recently returned to Linux for production, too tired of windows.
I run one for my workstation with a K6000 only and the other with a M6000 + 1080Ti on a centOS7.7 with a KMOD isntalled driver 430.50.
the one with the M6000 + 1080Ti doesn’t keep my screen resolution for the Z31 HP after reboot.

I run a HP Z840 and have a HP Z31 on each ws, the one with the K and the one with the M. I use those Quadro to drive the 10bit monitors for color purposes in my CG and Comp workflow.

I checked the xorg.conf:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 430.50

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"


Section “Monitor”

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Ancor Communications Inc ASUS PB278"
HorizSync       24.0 - 99.0
VertRefresh     24.0 - 76.0
Option         "DPMS"


Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro M6000”
BusID “PCI:6:0:0”

Section “Screen”

Removed Option “metamodes” “DP-2: +0+720, DP-6: 4096x2160 +2560+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-3"
Option         "metamodes" "DP-2: nvidia-auto-select +0+0, DP-6: 4096x2160 +2560+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24


Obviously, the nvidia-auto-select is one guys I change back to 4096x2560 but never stays.
The 1080Ti is not really present as its own 1080Ti code.

The lsci output gives me those 2 addresses:

06:00.0 VGA compatible controller: NVIDIA Corporation GM200GL [Quadro M6000] (rev a1)
84:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)

Is there a way to have those 2 babes cohabiting and being fully registered by my system as well as having my resolution being stored and used at reboot ?

Thank you in advance,


Gnome has its own monitor manager which you’re working against by setting monitor arragement in xorg.conf.
Please comment out the metamodes, delete ~/.config/monitors.xml and after reboot, arrange the monitors in gnome control center.

Thank you Generix