Make Error

Hi guys

I have been following the installation procedure for Isaac Sim, all the way to the last step to build with the command

make && make IsaacSimProjectEditor

I ran into the following error

(base) root@0b48b68c98be:/RL/Nvidia-issaac-sim/UnrealEngine-IsaacSim_1.2# make && make IsaacSimProjectEditor
bash “/RL/Nvidia-issaac-sim/UnrealEngine-IsaacSim_1.2/Engine/Build/BatchFiles/Linux/Build.sh” CrashReportClient Linux Shipping
Fixing inconsistent case in filenames.
Setting up Mono
Building CrashReportClient…
Creating makefile for CrashReportClient (no existing makefile)
Performing full C++ include scan (no include cache file)
Building UnrealHeaderTool…
Creating makefile for UnrealHeaderTool (no existing makefile)
Performing full C++ include scan (no include cache file)
------- Build details --------
Using system toolchain.
Using clang (/usr/bin/clang++) version ‘6.0.0’ (string), 6 (major), 0 (minor), 0 (patch)
Using bundled libc++ standard C++ library.
Using lld linker
Using ar and ranlib: /usr/bin/ar, /usr/bin/ranlib
Using fast way to relink circularly dependent libraries (no FixDeps).

Performing 30 actions (40 in parallel)
[2/30] Compile PCH.CoreUObject.h
[3/30] Compile SharedPCH.Core.h
[1/30] Compile PCH.Core.h
[4/30] Compile Module.BuildSettings.cpp
[5/30] Compile Module.UnrealHeaderTool.cpp
[6/30] Link (ld) libUnrealHeaderTool-BuildSettings.so
[7/30] Compile Module.Core.6_of_9.cpp
[8/30] Compile Module.Core.7_of_9.cpp
[9/30] Compile Module.Core.8_of_9.cpp
[10/30] Compile Module.Core.9_of_9.cpp
[11/30] Compile Module.Core.5_of_9.cpp
[12/30] Compile Module.Core.4_of_9.cpp
[13/30] Compile Module.Core.3_of_9.cpp
[14/30] Compile Module.Core.2_of_9.cpp
[15/30] Compile Module.Core.1_of_9.cpp
[16/30] Compile Module.Json.cpp
[17/30] Compile Module.ApplicationCore.cpp
[18/30] Compile Module.Projects.cpp
[19/30] Compile Module.CoreUObject.3_of_6.cpp
[20/30] Compile Module.CoreUObject.2_of_6.cpp
[21/30] Compile Module.CoreUObject.1_of_6.cpp
[22/30] Compile Module.CoreUObject.6_of_6.cpp
[23/30] Compile Module.CoreUObject.5_of_6.cpp
[24/30] Compile Module.CoreUObject.4_of_6.cpp
[25/30] Link (ld) libUnrealHeaderTool-Core.so
[26/30] Link (ld) libUnrealHeaderTool-Json.so
[27/30] Link (ld) libUnrealHeaderTool-ApplicationCore.so
[28/30] Link (ld) libUnrealHeaderTool-Projects.so
[29/30] Link (ld) libUnrealHeaderTool-CoreUObject.so
[30/30] Link (lld) UnrealHeaderTool
Total build time: 42.96 seconds (Local executor: 36.28 seconds)
Parsing headers for CrashReportClient
Running UnrealHeaderTool CrashReportClient “/RL/Nvidia-issaac-sim/UnrealEngine-IsaacSim_1.2/Engine/Intermediate/Build/Linux/B4D820EA/CrashReportClient/Shipping/CrashReportClient.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -NoEnginePlugins
Refusing to run with the root privileges.
Error: UnrealHeaderTool failed for target ‘CrashReportClient’ (platform: Linux, module info: /RL/Nvidia-issaac-sim/UnrealEngine-IsaacSim_1.2/Engine/Intermediate/Build/Linux/B4D820EA/CrashReportClient/Shipping/CrashReportClient.uhtmanifest, exit code: Canceled (1)).
Makefile:267: recipe for target ‘CrashReportClient-Linux-Shipping’ failed
make: *** [CrashReportClient-Linux-Shipping] Error 1

Let me know what I can do to fix the error

Hi Charubutr,

I think you haven’t done the previous steps correctly, because it doesn’t seem to find your make file.

Liila

You cannot run the build using root
“Refusing to run with the root privileges.” Is the error that causes the build to fail.

I have the same error in this step. and make sure there is no other error information in the previous steps.

can be fixed by the following command:

chown -R user: filepath su user
$ make