Makefile not found even after running cmake (make: *** No targets specified...)

I followed these commands from the dusty-nv tutorial and landed up in the following error as shown-

Commands I followed (in order):
sudo apt-get update

sudo apt-get install git cmake libpython3-dev python3-numpy

cd ~/Downloads

git clone --recursive GitHub - dusty-nv/jetson-inference: Hello AI World guide to deploying deep-learning inference networks and deep vision primitives with TensorRT and NVIDIA Jetson.


cd jetson-inference

mkdir build


cd build

cmake …/
The following message was seen:
–Configuring incomplete, errors occurred!

green white dialog box seen
Clicked on square bracket (asterisk appeared) near pytorch installation option
then clicked on OK

make -j$(nproc)

The following error message was seen:
make: *** No targets specified and no makefile found. Stop.

Please resolve my error at the earliest. Thanks.

Hi @sana.sampson21, can you provide the log from when you ran cmake (or rm build and try again) so we can see the error? Or try running the jetson-inference container to get started.

I referred to the video Real-Time Object Detection in 10 Lines of Python Code on Jetson Nano by dusty_nv

When I ran the command cmake …/, it led to a window which showed an option to install PyTorch, it did not show the window containing the list of pretrained models, the way it was seen in the video.

cmake …/ ran with this error:
–Configuring incomplete, errors occurred!

Also, the log file from cmake has been attached as you requested.
CMakeOutput.log (44.0 KB)

I tried running using docker container but storage seems to be an issue.
On running docker/ command, the terminal shows the following error:
docker: write /var/lib/docker/tmp/GetImageBlob4261650125: no space left on device.
See ‘docker run --help’.

Didn’t install anything extra other than the docker container within nvdli-data for two courses:

  1. Getting started with AI on Jetson Nano
  2. Building Video AI Applications at the Edge on Jetson Nano

Hi @sana.sampson21, sorry for the delay - that video is several years old, and the model downloader window has been removed in lieu of the models being automatically downloaded for you when you first try to load them. So it’s normal not to see that.

If you are still facing issue, please paste the terminal output from when you run CMake - not CMakeOutput.log, this does not contain any errors.

Those two containers can take up a lot of storage too, so you would either need to remove them using sudo docker rmi ... or mount additional storage (like NVME, larger SD card, ect). Also those DLI containers are for the original Jetson Nano and JetPack 4 and aren’t supported on JetPack 5.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.