Mass Flash on with connect tech carrier board


I am trying to use the to create the massflash Tarball for jetson tx2i + connecttech. I edited the original jetsontx2i.conf to include the DTB from connectech and also the cti-tx2i.conf.common.

source “${LDK_DIR}/cti-tx2i.conf.common”;

then i run sudo ./ jetson-tx2i mmcblk0p1. But i get the following error:

Error: missing ODMDATA not defined.
**** ERROR: flashcmd.txt generation failed.*

Can someone help? Is it something that needs to be supported by the carrier board provider?

hello visionnvidia,

please refer to p2771-0000.conf.common,
there’s function, process_board_version(), to parse board version and assign ODMDATA accordingly.

since you’d edit the board configuration file to exclude that, you may adding this by yourself.

are there any differences in using the nvmassflashgen + nvmflash with connect tech boards?
will it do a custom image deployable to other production connect tech devices if using the nvmassflashgen, or necessarily using the for cloning the app partition for further use with nvflashmassgen -r or without nvmassflashgen will be required?
With multiple continious attempts I am observing the situation when nvmflash completes successfully but the jetson unit doesn’t boot or show any outputs after reflashing with nvmflash
only restores by flashing in a workable way but it has a bunch of remnants if using it for restoring to other devices

hello Andrey1984,

for the normal flash process, you’ll need download the JetPack release via SDKManager and enter the path to call the for image flashing. you’ll need the target device connected and enter forced-recovery mode for running the -G cloning options.

in the other hand,
if you’re using, it’ll create a tarball file to include not only the release binaries, but also the python scripts to perform the flash process. it’s due to you’re able to deliver this tarball file to the factory floor to deploy image flashing.
you may also review the content of mfi_${ext_target_board}/

it looks like you’re having some issue there,
this topic has been mark as solved, could you please initial another new thread for tracking,

let’s follow-up the issue at Topic 189508.