max_mtu on centos5 vs. centos6

Hi,

I am using ConnectX-2 cards in connected mode for IB tests

centos5:

ibv_devinfo | grep max_mtu

max_mtu: 2048 (4)

centos6:

ibv_devinfo | grep max_mtu

max_mtu: 4096 (5)

qperf test run fine.

When testing with ib_* tools I need to specify lower MTU explicitly for the test between centos5 and centos6 to suceeed for example

‘ib_write_bw -m 2048’ on centos6 node

Is there a way to increase max_mtu on centos5 to 4096 while keeping vendors kernel?

this worked as expected

Centos 5 has now 4096B IB MTU and ib_* tools work without forcing mtu size

thank you very much yairi

You should be able to increase the MTU also on CentOS6.

Edit your modprobe.conf and add the following line:

options mlx4_core set_4k_mtu=1

Restart the driver… that should do it.