MAX3232 3.3V-5.5V RS232 to TTL Converter Module for UART debugging (SOLVED)

I am trying to use an old MAX3232 module I had lying around as my serial debugging adapter and I have a quick question about wiring the up to the J21 header.

I followed the guides and wired up tx, rx and ground but I was not getting a successful connection through minicom so I assume I need to connect the 5v/3.3v VCC in order for the MAX3232 to function correct?

Where can I safely connect the 5v/3.3v VCC on J21 to use this MAX3232 for UART debugging?

Here is a similar module:

From this pinout looks like I can use pin2 for 5v or should I use pin 1 for 3.3v?

Before connecting the 5V you may need to find out if that is a 5V input or a 5V output…if output, don’t connect it. If it is a supply input requirement, then J21 can probably supply this (just be very certain your adapter uses this as input, not output).

The RXD/TXD I/O must be 3.3V (“TTL” logic levels).

I saw in a data sheet that the RXD/TXD of the header mentions 5V, which might be just their way of saying “3.3V TTL logic levels using 5V TTL devices”…but unless you specifically know I/O signals are 3.3V don’t use it. You could easily attach an oscilloscope (assuming you have one) and test if sending data results in approximately 3.3V…if it is a 5V signal, then you shouldn’t use it.

Thanks for the reply linuxdev. I havent even tried to connect the VCC yet (I have a adafruit USB to TTL on the way so this was just an idea).

From the specs found on the web:

Operating Voltage: 3.3V~5V

Four Interface: VCC, GND, RXD, TXD

Can be used in STC SCM, STM32 SCM, NXP SCM,NEC SCM

I dont see anything about 5v output so I assume its 3v/5v input from board to max3232.

The last thing I want to do is fry something. I was hoping someone in here has used the max3232. I just wanted a temporary solution until the USB-TTL came in. I feel lost without UART debugging ;)

Looks to be completely possible as the same module can be used on the pi:

“I tried switching the RS232-to-TTL converter VCC to the 5V branch of RPi GPIO instead of 3.3V (with confidence, because the datasheet of MAX3232 chip claims it can take anything between 3V3 and 5V as input) and it started working!”

Looks like the VCC needs 5v/3v input and DOES NOT output voltage.

I am thinking that this would work connecting VCC to pin 2 of J21 but I really dont want to fry my carrier board (not even sure if NVIDIA sells just the carrier board and how much if so?)

linuxdev do you think am I safe to use pin 2 for 5v VCC?

And this here looks to be a great write up on how to use the MAX3232.

I am going to test the module on a router or arduino I have lying around and make sure it functions and then ill attempt the connection on my precious TX1 ;)

I will report back results…

The writeup indicates the MAX3232 does use 3.3V I/O, so it is compatible. It also implies the +5V is an input. I’m not where I can check right now, but measure pin 2 of J21, this is probably 5V. You won’t use CTS/DTS, just GND, TXD+/RXD-…so settings are 115200 8N1 as normal, but software flow control.

Great! Thanks for the confirmation linuxdev! I will also confirm that this module indeed works after the initial test later today. I will also make sure to test the voltage of pin 2 to make sure it is 5v.

I measured pin 2 and can confirm it is indeed +5v.

Working absolutely perfect! Used some 10 pin headers and an old USB cable and I now have myself a working UART debug console :D

I did end up using pin 2 for the 5v VCC input.

Thanks for the input linuxdev!