MDIO and MDC doesn't work

[ 1382.190712] mv88e6085 2310000.ethernet:02: probing switch. n=1
[ 1382.190892] mv88e6085 2310000.ethernet:02: <- addr: 0x10 reg: 0x03 val: 0x0000

It seems you could not read register and detect Marvell 88E6352 with R35.4.1.

Could you share the result of following command on both R35.1(work) and R35.4.1(failed)?

$ sudo cat /sys/kernel/debug/gpio|grep PG.05
$ cat /proc/device-tree/ethernet@2310000/nvidia,phy-reset-gpio

It seems you didn’t configure the pull for PG.05.
Could you share the pinmux spreadsheet for your configuration for PG.05 (ENET_RST_N)?

Thank you reply,I did not use pinmux spreadsheet,I modify this file directly and then refresh orin

Linux_for_Tegra/bootloader/t186ref/BCT/tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi

R35.4.1
titan@titan:~/Desktop$ sudo cat /sys/kernel/debug/gpio|grep PG.05
[sudo] password for titan:
gpio-388 (PG.05 |phy_reset ) out lo
titan@titan:~/Desktop$ cat /proc/device-tree/ethernet@2310000/nvidia,phy-reset-gpio
5

R35.1
titan@titan1:~/Desktop$ sudo cat /sys/kernel/debug/gpio |grep PG.05
[sudo] password for titan:
gpio-388 (PG.05 |phy_reset ) out hi
titan@titan1:~/Desktop$ cat /proc/device-tree/ethernet@2310000/nvidia,phy-reset-gpio
5

This my Linux_for_Tegra/bootloader/t186ref/BCT/tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi

tegra234-mb1-bct-pinmux-p3701-0000-a04.txt (63.6 KB)

If you don’t set reset-gpio in device tree but control it with sysfs instead, will the driver starts to work?

Using sysfs to control reset-goio is still the same as it is now, the driver is not working.

After a manual reset using sysfs,I manually loaded the nvethernet.ko driver,but eth0 still unavailable
titan@titan:~/Desktop$ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 1523 bytes 106016 (106.0 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1523 bytes 106016 (106.0 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

rndis0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c2:d8:6b:4a:7d:49 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.43.100 netmask 255.255.255.0 broadcast 192.168.43.255
inet6 fe80::b5ea:f62d:a9ce:ffaf prefixlen 64 scopeid 0x20
ether ae:0c:29:a3:9b:6d txqueuelen 1000 (Ethernet)
RX packets 60 bytes 2678 (2.6 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 539 bytes 42054 (42.0 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c2:d8:6b:4a:7d:4b txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

titan@titan:~/Desktop$ ifconfig -a
dummy0: flags=130<BROADCAST,NOARP> mtu 1500
ether 22:1c:0d:6d:7c:3c txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 48:b0:2d:95:10:31 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

l4tbr0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether c2:d8:6b:4a:7d:49 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 1607 bytes 111894 (111.8 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1607 bytes 111894 (111.8 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

rndis0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c2:d8:6b:4a:7d:49 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.43.100 netmask 255.255.255.0 broadcast 192.168.43.255
inet6 fe80::b5ea:f62d:a9ce:ffaf prefixlen 64 scopeid 0x20
ether ae:0c:29:a3:9b:6d txqueuelen 1000 (Ethernet)
RX packets 62 bytes 2734 (2.7 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 564 bytes 43991 (43.9 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c2:d8:6b:4a:7d:4b txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

this is load the driver log
[ 527.149990] nvethernet 2310000.ethernet: Adding to iommu group 58
[ 527.150341] nvethernet 2310000.ethernet: failed to read skip mac reset flag, default 0
[ 527.150345] nvethernet 2310000.ethernet: failed to read MDIO address
[ 527.150351] nvethernet 2310000.ethernet: setting to default DMA bit mask
[ 527.150369] nvethernet 2310000.ethernet: missing nvidia,pad_auto_cal_pu_offset, setting default 0
[ 527.150372] nvethernet 2310000.ethernet: missing nvidia,pad_auto_cal_pd_offset, setting default 0
[ 527.150506] nvethernet 2310000.ethernet: failed to get phy reset gpio error: -2
[ 527.155597] nvethernet 2310000.ethernet: Ethernet MAC address: 48:b0:2d:95:10:31
[ 527.157046] -->macsec_probe()
[ 527.157078] nvethernet 2310000.ethernet: macsec param in DT is missing or disabled
[ 527.157083] <–macsec_probe()
[ 527.157086] nvethernet 2310000.ethernet: Macsec not supported/Not enabled in DT
[ 527.158546] nvethernet 2310000.ethernet: eth0 (HW ver: 53) created with 8 DMA channels
[ 527.193123] nvethernet 2310000.ethernet: failed to connect PHY
[ 527.199309] net eth0: ether_open: Cannot attach to PHY (error: -19)
s

Is this from JP5.1.2(failed) or JP5.0.2(working)?

Could you use pinmux spreadsheet to configure this pin as following?

Thank you very much, this problem is now solved

Could you share the root cause to help others hitting the similar issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.