Mellanox Connect-4 not working with PF NAT on FreeBSD 12.1

Hello support.

Recently bought Connect-4 NIC.

Setuped server on FreeBSD 12.1 loaded drivers etc

When trying to NAT with PF some networks, got massive errors:

all udp x.x.248.6:62551 (x.x.0.134:37110) → 8.8.4.4:53 SINGLE:NO_TRAFFIC

if i change upstrean nic to re0 all working fine.

Are there any bugs or known problems with solutions on problem?

Hello Andrew,

Thank you for posting your inquiry to the Mellanox Community.

To our knowledge, there are no known issues with FreeBSD 12.1 supporting Mellanox Adapters.

Likely, this is a PF configuration issue. This link is very helpful in regards to configuring PF:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/firewalls-pf.html

Also, the FreeBSD PF mailing list is an excellent community resource available to you for troubleshooting configuration-specific questions:

https://lists.freebsd.org/mailman/listinfo/freebsd-pf

Best regards,

Mellanox Technical Support

Hello support.

I solved this issue. In general problem wasnt in PF, but in routing caused by drivers.

It wasnt enough to do:

kldload ml5

kldload mlx5en

Those drivers allow NIC to work as internet clinet, without possibility to NAT, and route traffic

Problem was solved after rebuilding kernel with options below

options OFED

options SDP

options IPOIB_CM

options COMPAT_LINUXKPI

options RATELIMIT

device ipoib

device mlx5

device mlx5ib

device mlx5en

device mthca

device xz

device mlxfw