Mellanox ConnectX-4 is incompatible with AMD Ryzen 9 5950X and CentOS

It would appear that no matter which way I slice and dice it, the Mellanox ConnectX-4 card (MCX456A-ECAT) is incompatible with an AMD Ryzen 9 5950X and CentOS (I’ve tried both 7.7.1908 and 7.9.2009).

My MCX456A-ECAT has already been updated to the latest firmware and I am using MLNX_OFED_LINUX- (which is the latest drivers available for it) and it still results in problems.

If I use the “inbox” drivers, it results in a kernel panic (and I’ve already tried reaching out to the CentOS team about it).

If I try to use the MLNX OFED drivers, openibd fails to restart after the installation of the driver or fails to start properly when the system is rebooted.

Hi Chan

With limited info, it’s hard to give a right answer.

i’d like you to open a CASE and contact a supporter.

Meanwhile, could you please double check if there are some errors

  1. #dmesg
  2. /var/log/messges
  3. /etc/init.d/openibd status

could you please re-install OFED and collect below and open a CASE with thoes?

  1. OFED installation logs
  2. ConnectX-4 snapshot file
  3. /etc/init.d/openibd status

  4. #dmesg