Mellanox CX5 isn't showing PASID Capability on lspci


I’m working with Mellonox CX-5 CDAT, I don’t see the PASID capability ID 0x001B on the extended capability address space when I get the hexdump using the lspci.

I’m using Intel processor and enabled the VT-d on BIOS as well. Kernel Version is 5.15.0-69-generic

Hello bgodi,

Thank you for posting your query on our community.

Please make sure to enable ATS in BIOS and then enable it on the card using mlxconfig as below:
mlxconfig -d /dev/mst/mt4123_pciconf0 set ATS_ENABLED=1

For more details: 2

Thanks & Regards,
Nvidia Support

Hi Sribhargavid,

Thank you for the response, I did what you recommended and I didn’t see any difference. I enabled the VT-d (ATS, I didn’t find anything exclusively that says ATS on Aptiov) and on the drivers I enabled the ATS_ENABLED flag. I see the ATS capability structure on lspci but not the PASID capability structure.

I used other graphics card with PASID capability that is showing up on lspci in the same environment. So, I’m striking out the kernel modules/BIOS enablement/and any other environment settings.

Thank you,

Hello Bharath,

Thank you for your quick response. PASID is a feature that can be enabled in the context of ATS.
ConnectX-5 don’t enable it and don’t support it in the FW.

Thanks & Regards,
Nvidia Support