Memory leak on 430.26 drivers without X

When i use system with 2x Quadro M4000 GPUs running without Xorg, and when i set nvidia-smi -pm 1, then every call to nvidia-smi will result into new process of [nv_queue] which will not close when nvidia-smi command will close.

I tried this on Debian Stable kernel 4.9 and also Debian Stable Backport kernel 4.19 with same issue.

This will not happend on system with Xorg running.

After short time when there is alotof nvidia-smi requests on system, system then will became slower.

On system with 418.56 there is no such process as [nv_queue], so this issue is something new in 430.XX drivers.

Hi Thunderm,

We have internally filed a bug 200531504 for tracking purpose and able to repro issue locally.
Our engineering team is working on it and will keep you updated.


I am seeing this same issue on centos, has it been solved in a more recent version of the driver?
in my case there are 8156 nv_queue processes (and counting).


Hi mher, I had encounter the same issue on my ubuntu with 430.40 and all the problems gone after I upgraded the driver to the latest version (440.44).
I think it’s worth a try.