MGA G200eW WPCM450 not work with nVidia K40 GPU on Fedora or Centos

We have purchased a SuperServer 4027GR-TR server recently and installed 8 pieces of nVidia K40 GPU accelerators on the server. We tried installing Fedora 20, 21 Linux and Centos 7 Linux. When I ran the ispci command, it showed the vga chipset was MGA G200eW WPCM450. After installation, the system showed Gnome X login screen and worked properly. However, when I installed the nVidia driver
(NVIDIA-Linux-x86_64-340.65.run) and rebooted, the system could not show Gnome X login screen and showed the below error message:

=======================================================================
Oh no! Something has gone wrong. A problem has occurred and the
system can’t recover. Please log out and try again.

    It seems that the MGA G200eW WPCM450 chipset could not be used after we installed the nVidia driver. Could anyone please give a hand? Thanks.

Additional information:
Error message from /var/log/Xorg.0.log

=================================================================================================
[ 492.579] (EE) NVIDIA(0): mga: The PCI device 0x532 at 14@00:03:0 has a kernel module claiming it.
[ 492.579] (EE) NVIDIA(0): mga: This driver cannot operate until it has been unloaded.

From the error message, the BusID “PCI:14:3:0” seems to be used by nVidia kernel module.
nvidia-bug-report.log.gz (1.17 MB)