Micro-USB connection breaks

Hello here!

I am trying to boot the jetson nano from my Windows 11 based Ubuntu 18.04 vm using a micro-usb cable. The SDK Manager recognizes the connected device, but after the installation of jetson nano modules, when I start to flash, the connection breaks down within seconds, and the process fails.

In the end I managed to flash from another host PC, but the ssh connection is still not working properly between the original host and the jetson. The connection breaks after 5-15 seconds in all cases down:

“client_loop: send disconnect: Connection reset”

I didn’t have any problem earlier connecting my PC to another PC/Embedded device via ssh, and this issue occurs even if I use other jetson nano modules.

VMs are not supported. They have issues with USB (Jetsons disconnect and reconnect during flash, VMs tend to not reconnect correctly). If you are using WSL2 for flashing, then even if you fix the USB flash will still fail. WSL2 lacks the required loopback feature (I’m told this can be added, but doing so is not trivial; other VMs tend to work ok for loopback).

If you are going to develop for a Nano you’d be better off dual booting to a native Ubuntu 18.04.

Incidentally, each VM manufacturer has different setup instructions. You’d need to consult their documentation to figure out USB.

I was using Oracle Vm, which definetly couldn’t handle the flashing process (disconnect and reconnect), after the first disconnect it could not go on.

I changed to VMware and now everything works fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.