Microsemi switch 8534 from Pegasus communication problem

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04


I have a problem with the microsemi 8534 switch from the Pegasus E3550.
I created a new configuration from the chiplink software with an NTB between the Xavier A and a Linux host pc. I flashed the configuration, rebooted the Linux pc and the Pegasus board and loaded the drivers, an error occurred and I had to modify a little bit the configuration.
I reflashed with the new configuration and the switch stopped responding.
I can connect to it via console but I cannot do any input and I cannot see any output.
I want to mention that the switch is running the firmware with support for ntb.
How can I reset the switch to a working condition?


Hi @AndreiNvidia ,

Please try if Flashing the PCIe Switch Configuration/Firmware from NVIDIA DRIVE Xavier A or reflashing DRIVE OS 5.2.0 with SDK Manager helps on your problem. Thanks.

Hi VickNV,
I’ve tried [Flashing the PCIe Switch Configuration/Firmware from NVIDIA DRIVE Xavier A] the issue is that I cannot see the device like “/dev/switchtec0” there is no device switchtec0.
I also tried reflashing the Xavier A and A with SDK Manager. Thanks.

Please try if the device node is there after cold booting (don’t run “reboot” command).

Did you mean you ran through the DRIVE OS 5.2.0 installation (flashing Xavier A and B) in SDK Manager and it didn’t help?

I’ve done a cold boot both on the Pegasus and on the Linux pc, there is no device node.
Yes, I’ve ran through the DRIVE OS 5.2.3 installation(flashing both Xaviers) and that didn’t help.

I’ve also attached a block diagram of our setup.

This forum is only for devzone releases (avaliable in NVIDIA DRIVE Downloads | NVIDIA Developer).
DRIVE OS 5.2.3 isn’t a devzone release, I assume you have other support channel.
If you don’t know it, please contact with your nvidia rep to understand who can support you. Thanks.