Midi sequencer not present

I am using a USB sound card connected to the Xavier development kit, I need both audio and midi for my application.
I get this error while loading the Jack Audio Daemon:

jackd -P89 -dalsa -dhw:2 -r44100 -p256 -n3 --midi seq

ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory

I tried to load the kernel module:
sudo modprobe snd_seq

modprobe: ERROR: …/libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name=‘snd_seq’
modprobe: ERROR: could not insert ‘snd_seq’: Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: …/libkmod/libkmod-module.c:979 command_do() Error running install command for snd_seq
modprobe: ERROR: could not insert ‘snd_seq’: Operation not permitted

Thanks,

I’ve not set up a sequencer, but the files in “/dev/” are not real files…these are the result of a driver. Missing that file means you need to add the feature in the kernel. Most likely you could just build a module and add that as a file copy to “/lib/modules/$(uname -r)/”. Someone else may know which module(s) you need for this.

Thanks linuxdev.

I am having the same issue with a Jetson Nano; @Codepex, did you find a solution?
What module does one need to load to have access to snd_seq?

batchku, sorry I did not have time to look at it yet

Thank you @codepex.
Maybe @linuxdev has some insight?

For anyone else trying, I followed these instructions to rebuild the kernel, with the ALSA sequencer module enabled:

I haven’t worked on MIDI, so I don’t know of a specific module. About all I can do is refer to the mechanics of modules for a case of modules or kernel compile itself being the issue (my original post relates to either searching in the wrong place for the module…the uname -r stuff…or the side effect of missing modules…the /dev stuff…and a bad module search location equals a missing module even if the module is present).