Mint 19.2 on AMD Ryzen 5 Laptop with GTX 1650 card, Graphics drivers issues.

What’s the output of
ps aux |grep X
in your case?
“no protocol specified” sounds like you didn’t run it as root, i.e. you didn’t open a root shell beforehand.

sorry my mistake i didnt read youre post correctly

ps aux |grep X gave me this

root 993 0.3 1.5 2703836 113668 tty7 Ssl+ 14:18 0:00 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
dwinters 1348 0.0 0.0 22624 1292 tty1 S+ 14:19 0:00 xinit /etc/X11/xinit/xinitrc – /etc/X11/xinit/xserverrc :1 vt1 -keeptty -auth /tmp/serverauth.5q9T7lSKlC
dwinters 1349 5.0 2.9 2907608 207820 tty1 Sl 14:19 0:09 /usr/lib/xorg/Xorg -nolisten tcp :1 vt1 -keeptty -auth /tmp/serverauth.5q9T7lSKlC
dwinters 2383 0.0 0.0 14440 1000 pts/0 S+ 14:22 0:00 grep --color=auto X

So my display command should look like this am i correct

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/ xrandr --output eDP-1-0 --off
DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/ xrandr --output eDP-1-0 --auto

inputting these command give me an error
No protocol specified
Can’t open display :0

sorry my mistake forgot the :0

with those commands i get

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 xrandr --output eDP-1-0 --off
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 7 (RRSetScreenSize)
Serial number of failed request: 30
Current serial number in output stream: 32

with the second command my display comes on but after a restart it is black again

UPDATE: It seems that only the login screen doesnt come up after inputting my password i get to the desktop. with one weird thing.
If i enable my second monitor eveything is drawn with a black square around it for only a second
really annoying

Update2: If i disable my laptop monitor the screen draws correctly.
But i would like to have both screens on.
Any suggestion for this?

Please try this:
edit the file /sbin/prime-offload
adding
xrandr --output eDP-1-0 --auto
at the end and reboot. If that doesn’t help, try adding
sleep 2
before the added xrandr command.

About the “black square” issue:
please switch from amdgpu to modesetting in
/usr/share/X11/xorg.conf.d/10-amdgpu.conf
by replacing

Driver "amdgpu"

with

Driver "modesetting"

tried modesetting
i get a background but all the user interface elements flicker.

BUT

When i then set it back to amdgpu the flcikering whent away and also the black squares are gone
i still have the nvidia renderer so that is good.

i still dont get a login screen and must type my password blindly to login
any suggestions about that?

It is not a huge problem because i now have nvidia drawing my screens

Did you add the suggested commands to /sbin/prime-offload?

yes i did
it didn`t work
black screen but after i typed in the password i got to the desktop

Does it work if you add
sleep 1
xrandr --output eDP-1-0 --off
xrandr --output eDP-1-0 --auto
at the end?

Sorry for the very late reply
Yesterday i was unavailable.

i tried
sleep 1
xrandr --output eDP-1-0 --off
xrandr --output eDP-1-0 --auto

in /sbin/prime-offload

still no logon screen.

You could try changing “sleep 1” into “sleep 4” and then check if waiting for 4 seconds makes the login appear.
Did you ever check if the bios allows for setting the amd gpu’s vram?