[Mint 19; HDMI Handshake?] Irregular Audio Dropouts during Multichannel Playback

Hello, NVidia team! I posted this bug over on the Mint Forums in September. When playing multichannel (e.g. 5.1 surround) music, the audio randomly drops out. I wonder if it had something to do with HDMI implementation in the NVIDIA driver. Perhaps a handshake issue?

I experienced this bug in Ubuntu for over 8 years, and that finally went away when I switched to Mint in 2017. In September, it started happening in Mint, too.

I have since moved to Germany and set up a new 7.1 system here with all-new HDMI cables and a new receiver. Issue still occurs. Any help will be greatly appreciated.

===========================================

Steps to Reproduce:

  1. Start up Linux Mint 19
  2. Launch e.g. VLC, SMPlayer, Parole or similar
  3. Listen to multichannel music (e.g. 4.0, 5.1, 7.1 surround) until issue occurs

Current Results:
While listening to multichannel music (e.g. in FLAC format, or .mka, .mkv, .ac3, .dts, .iso…), there are occasional audio dropouts.

Expected Results:
All music should play back without issue.

Notes:

  • Repro rate: unpredictable. Sometimes no issue for days, sometimes 3-4 dropouts in just 5-6 consecutive songs
  • Issue never occurs at the same point in a song twice
  • Issue used to occur in Ubuntu when I was using it between March 2009 and November 2017
  • Issue stopped occurring when I switched to Mint in November 2017
  • Issue first encountered in Mint on September 8, 2018
  • Issue occurs on both my desktop and laptop PC (encountered on Sep 8th and 9th, 2018, respectively, and again since setting up my new 7.1 system on Nov 19th)
  • Issue never encountered in stereo music in MP3, OGG or FLAC format.

Resources:

  • This is what the dropout sounds like: https://trac.videolan.org/vlc/attachment/ticket/21102/audio-dropout-example2.flac
  • The following bug in VLC has similar symptoms, but only happens with faulty FLAC files and has a 100% repro rate: https://trac.videolan.org/vlc/ticket/21102
  • Back in January, on an unrelated matter, I did some research on Mint's audio implemenation and found that it uses different codecs than Ubuntu ("lavc:" as opposed to "ffmpeg", fwiw). I thought they might be the reason Mint never had these dropouts. Has anything about these codecs been changed with a recent Mint update? I don't see them installed anymore when checking the codecs list in SMPlayer. Cf. this Facebook post: https://www.facebook.com/groups/linuxmintmembers/permalink/10157037652629358/
  • Bug report/thread in Mint Forums: https://forums.linuxmint.com/viewtopic.php?f=48&t=277245&p=1523743#p1523743

Free 5.1 multichannel music available here:
http://www.2l.no/hires/
https://gumroad.com/l/surround/free
https://velcrocranes.bandcamp.com/
https://www.lynnemusic.com/surround.html
https://surroundmusic.one/streaming/

Hardware specs - my desktop PC:
Sound device: NVidia GeForce GTX 1080Ti (HDMI out)
Playback hardware: Denon AVR-X1400H 7.2 surround receiver (HDMI in)
RAM: 32 GB
CPU: Intel Core i7-4970K (4.00GHz x4)
NVIDIA driver: 396.54

Hardware specs - my laptop PC:
Sound device: NVidia GeForce GTX 980M (HDMI out)
Playback hardware: Denon AVR-X1400H 7.2 surround receiver (HDMI in)
RAM: 32 GB
CPU: Intel Core i7-4710HQ (2.5GHz x4)
NVIDIA driver: 396.54
nvidia-bug-report.log.gz (150 KB)

Hello again, NVIDIA team! One thing I tried was to uninstall the NVIDIA driver and work with nouveau, but I ended up in low-res 2D mode with no HDMI support at all.

I now switched to 390.87. Put on some music and had the first dropout after 1 second of playback.

Is there anything you can suggest to stop these dropouts? I had none between November 2017 and September 2018, so there has to be something somewhere that works.

Any suggestion will be very greatly appreciated.

Despite the name, hdmi sound through the nvidia audio device is being handled by the module snd-hda-intel.
Use
grep snd /etc/modprobe.d
grep snd /lib/modprobe.d
to see what kind of module options are already set. Then you might try the options
power_save=0
and
enable_msi=on
e.g. create a file /etc/modprobe.d/99-snd-hdmi.conf containing

options snd-hda-intel power_save=0

and run
sudo update-initramfs -u
afterwards, then reboot.

Hey generix! Thanks so much for this! I will check it out.

EDIT: when I try the grep commands, I get an error message saying /etc/modprobe.d is a directory.

Sorry, has to be
grep snd /etc/modprobe.d/*
grep snd /lib/modprobe.d/*