MIPI camera stops operating depending on power and power consumption

Hello, I recently started working on a project again.

I would like to inquire because the symptoms I experienced while testing the Xavier NX module in the past are the same in the Orin NX environment.

Can you explain in detail the 3A in the forum topic you previously answered?

Regardless of power mode levels 0 to 4, in situations where there is only one camera, the camera operates without problems even if the power consumption is 10 to 20 W.

However, if there are two cameras, if the power consumption exceeds approximately 15W, one camera will stop operating.

You can prevent problems from occurring by customizing the settings of the nvpmodel.conf file so that power consumption does not exceed approximately 13W under appropriate specifications. However, this setting is not considered safe when taken out into the field.

Considering the symptom, I think it is related to the 3A (power consumption) I answered previously, so I would like to ask again.

Can you give me some advice on maritime symptoms?
And can you tell me how to debug in the current state?

Thanks.

hello JinSH,

it’s about basic camera operations, and software stack algorithms.
for instance, 3A they’re stands for… Auto Exposure (AE), Auto While Balance (AWB), and Auto Focus (AF).

Thank you for answer.
If so, can you tell me how to determine the cause of the symptom or what items to check?

If you set up the same environment using an IP camera or USB camera and connect multiple cameras, power consumption increases as the number of cameras increases, resulting in lower performance.
This is a natural result.

In camera environments other than mipi, video reception does not stop or problems occur with the program…

I would appreciate it if you could share how to debug it.

hello JinSH,

but… these are sensors sending data to ethernet, or USB interface.
how many camera stream you’ve enabled? it’s more like system configuration instead of camera software bug.

Two MIPI CSI-2 2Lane cameras are connected.


I am sharing approximate test photos.
Power Mode: MAXN
CAMERA: 2 MIPI CAMERAs
Power consumption when running program: approximately 13.3W

  • After receiving the first frame from the right camera, subsequent frames are not received.

Power Mode: CUSTOM

  • Only CPU and GPU maximum clocks are adjusted in MAXN mode
    CAMERA: 2 MIPI CAMERAs
    Power consumption when running program: approximately 11.6W

  • Normal operation without any problems

hello JinSH,

it’s not even high loading use-case per your screenshots,
we would like to reproduce this issue with some demonstrate app locally.
may I also know the Jetpack release version you’re working with now.


The Jetpack version used is version 5.1.1, and the Deep Stream version is version 6.2.

we’ll try to use the same setting to check locally. is it possible for sharing your nvpmode config.

nvpmodel.conf.txt (10.1 KB)

I am sharing the nvpmodel file.

In a maxn, 25W environment, there is a high probability of stopping.
It is not constant in a 15W environment.
When tested in a 10W environment, it operates stably.
I am using a customized conf file in 10W mode.

FYI,
we cannot reproduce this locally.
we’ve test with deep stream example to enable dual camera streaming, also by running with your nvpmodel config. (~10.7W)

Thank you for checking.

If so, please check one thing.

As power consumption increases, I would like to trace back and analyze the symptoms of errors occurring in camera video stream reading.

How can I check the camera CSI capture log & hardware error messages in detail?

hello JinSH,

camera failures it usually report error messages to kernel layer. you may check $ dmesg --follow for details.

or,
you could follow below steps to enable VI tracing logs, which report more low-level debug messages about MIPI packet status.
for example,

echo 1 > /sys/kernel/debug/tracing/tracing_on
echo 30720 > /sys/kernel/debug/tracing/buffer_size_kb
echo 1 > /sys/kernel/debug/tracing/events/tegra_rtcpu/enable
echo 1 > /sys/kernel/debug/tracing/events/freertos/enable
echo 2 > /sys/kernel/debug/camrtc/log-level
echo > /sys/kernel/debug/tracing/trace
cat /sys/kernel/debug/tracing/trace
# or, to review dynamic tracing log 
# cat /sys/kernel/debug/tracing/trace_pipe 

furthermore, please check developer guide for some Debugging Tips.

hello

When I previously tested the Deep Stream example with a dual camera, it was said to operate at ~10.7W.
Is it the same even if the power mode is set to MAXN?

according to Supported Modes and Power Efficiency, MAXN mode is an unconstrained power mode.