Missing files using carter/logmapper.

I have been trying to do some mapping using cartogropher.
From my understanding of https://docs.nvidia.com/isaac/isaac/packages/navigation/doc/cartographer.html, logmapper should basicly be plug and play once a recording is provided. I have done this but once running i get an error message:

F0613 11:14:42.771775 15134 configuration_file_resolver.cc:45] File ‘map_builder.lua’ was not found.

I have tried manually downloading, renaming and putting the cartogropher git repository so that the path for map_builder.lua lines up with “…/com_github_googlecartographer_cartographer/configuration_files/” but this did not work either.

Any help would be appreciated

Andreas have you checked our nightly build dated 5/28? Also next release is coming out in a few days.


I am currently working on the nightly build, but have not yet tried cartogropher on it since we got gmapping to work on that version.

Glad to hear a new version is comming soon, looking forward to it!