Missing libs and samples

Hi,

New Xavier board, JetPack-L4T-4.1.1-linux-x64_b57, Host is a fresh ubuntu16 with 100GB free, manually marked to install ALL the optional items.

Followed the setup instructions, got to the linux UI but it seems the libs and samples are missing.
Tried to re-install, same thing.

Logs seems ok, saw one line that might lead to something - the end of the “Terminal_Installation.log”:

Disable the ondemand service by changing the runlevels to ‘K’
Extracting the firmwares and kernel modules to /home/l/lic/Xavier/Linux_for_Tegra/rootfs
Extracting the kernel headers to /home/l/lic/Xavier/Linux_for_Tegra/rootfs/usr/src
tar: write error
Adding symlink /home/l/lic/Xavier/Linux_for_Tegra/rootfs/lib/modules/4.9.108-tegra/build --> /usr/src/linux-headers-4.9.108-tegra/kernel-4.9
Installing Image into /boot in target rootfs
Installing the board *.dtb files into /boot in target rootfs
Success!

Any ideas ?

I’m not sure from what is shown, but that looks like the flash step. Flash never adds extra packages or samples, and so anything up to that point won’t be relevant. Once that success step is reached the Xavier should reboot and then any picked packages installed. In the case of checking for installed system libraries (not samples) this should show all ok if flash worked:

sha1sum -c /etc/nv_tegra_release

Most of the extras will be somewhere under “/usr/local/”, though I think there might be something also in “/home/nvidia/”. You might want to say what specific sample you are looking for that looks like it isn’t there.

Also, do you have enough space on host ? My JetPack-4.1.1 setup used 43.5 GB on disk and it wasn’t a full install. On host check what gives:

df -H -T

and see if there is a disk that is full. If so, you’d have to free space in it or use another storage with enough room.
Last, you may also delete your JetPack folder and reload a fresh version.

Hi,

Tried again from fresh linux VM as host (100GB free disk space), fresh download - same results.

It seems like the the flash goes well but then the extra packages.
The sha1sum -c /etc/nv_tegra_release gives:
6961bd0b9b678789ba1cbf87d5a156ddd3447e8f

Also - After the device boots, no internet connection.

Q:
– How do you setup the internet via the host after flash and device boot ?
– Is there a way to install the libs/samples “manually” after flash and device boot ?
– Can it be a VM issue ? Is there install requirement to install from real host ?

Thanks again, Best
Danny.

VMs are known to raise issues for flashing. You’d better use a real Ubuntu host, but if you can’t have this you may search this forum for your virtualization solution (VMware, VirtualBox…), it mainly would be related to USB buffers and protocols.

Hi,

Thanks for all the answers, finally made it work by:

– Moving to physical host (not VM)
– Moving to ubuntu 18 on the host
– Adding (wired) internet connection, and booting the device after the flash burn (it didn’t recognise it till I boot) - I believe this is the critical action
– after the boot, run the jetpack installer again, choose only to install the packages (not flash the FS/OS), ignoring the requests for power/recovery mode and the matching error msgs and waiting till the actual install starts.

I’ve just spent a week or so fighting with the JetPack to get everything installed to use with Jetson Xavier. I initially tried to install JetPack 4.1.1 Developer Preview with an Oracle VirtualBox VM running Ubuntu 18.04 LTS and it was a royal waste of time. I was able to get things running, but down the road I got a lot of errors and problems.

You can read about my experience here: https://cudaeducation.com/jetsonxavier/

I figure that there is either an issue with the USB interface or the network settings. I discuss further in the link above.

I strongly recommend that you partition the drive on the host machine and install Ubuntu 18.04 LTS. The process is much cleaner and straightforward. Even if you get the VM running, you are still going to encounter problems later, so again I strongly recommend to install Ubuntu 18.04 LTS natively.

If you have nvidia gpu hardware on your host machine, you might run into problems with installing Ubuntu natively. Check out this link: https://cudaeducation.com/acpiexception/

If you have problems with the running the JetPack on the native Ubuntu 18.04 LTS install, check out this link: https://cudaeducation.com/jetpackstuckcomponentsmanager/

Hope this helps!

-cuda education
cudaeducation.com

Happy to hear!

-cuda education
cudaeducation.com