Missing nvvp.ini configuration file -- can't load large profile data in Visual Profiler

After installing CUDA ToolKit 10.0 (on a Mac), I was attempting to use the NVIDIA Visual Profiler (NVVP) to import a timeline profile, but I ran into a “Profile load failed” error noting that the file was too big.

The error suggest following the instructions (see link below), which say to edit the nvvp.ini file located in the libnvvp directory. However, I do not have that file in said directory (or anywhere I can find).

https://docs.nvidia.com/cuda/profiler-users-guide/index.html#large-data

I tried creating the file as specified in /Developer/NVIDIA/CUDA-10.0/libnvvp and restarting NVVP, but the import still failed for the same reason. (The profile is 1.9 GB and I set the configuration to allow 7 GB.)

I also tried un/re-installing and installing an earlier version, 9.2, but the file still did not exist.

Hi, jacobeau

Thanks for reporting this. We already have an internal reproduce of this issue.
Will let dev check.

Best Regards
Vera J

Hi

On Mac the nvvp.ini file is available under /Developer/NVIDIA/CUDA-10.0/libnvvp/nvvp.app/Contents/MacOS/

We will update the documentation. Please let us know if you still unable to find this file.


Thanks,
Ramesh