Missing Tegra components while flashing AGX board manually for patching the camera drivers

Hi there,

I manually flashed the AGX board to patch the camera drivers ( using official instructions for camera installation)

Although the OS boots up successfully and the camera works well, I realized that the Tegra components ( such as Cuda, tensorrt, cudnn ,…) have not been installed. I got this error for calling the ‘import jetson.inference’ inside the docker ===>> “libnppicc.so.10: cannot open shared object file”.

Based on this discussion (OTA update with custom kernel?), I tried to hold the main kernel packages such as (nvidia-l4t-kernel, nvidia-l4t-kernel-dtbs, nvidia-l4t-kernel-headers and kmod) for installation of Tegra components such as nvidia-l4t-cuda,…). However, it was not successful, as it tries to upgrade the main kernel packages which lead to losing the main custom kernel packages patched with camera kernels. Similarly, using SDK manager overwrites the main kernel packages.

I appreciate it if you could give me a solution for turning around this issue.

Thanks

hello parham.khojasteh1,

there’s developer guide, Over-the-Air Update.
it’ll by default access to the repo.download.nvidia.com and download the default release image. this usually overwrite your kernel and device tree binaries.

hence,
you could also refer to this session, Updating the Rootfs Partition with a Customized Updater and Image with your customize image.

for another approach, you could download [L4T Driver Package (BSP) Sources] via Jetson Linux | NVIDIA Developer to add your sensor driver and device tree, re-compile the kernel and update the platform to adapt to the latest release.
thanks

Thank @JerryChang

I tried the second approach that leads to the incompatibility between camera drivers and last Version of L4T driver packages as the e-con system provides only the camera drivers for L432.5.1 version for this NilieCAM25_CUXVR(NileCAM25_CUXVR – Global Shutter GMSL2 multi-camera solution) .
Regarding this https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3261/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html#wwpID0E0JB0HA , I didn’t get that what exactly I have to do? looks like a bit complicated for a machine learning person. Do you have other solutions for this issue?

Thanks

hello parham.khojasteh1,

please do not OTA to the latest release,
otherwise, suggest you contact with camera partner for the r32.6.1 drivers.

Hello @parham.khojasteh1,

Currently, we are developing our camera driver to support L4T32.6.1, and it will be released soon. To know the exact date of the release, please contact our support team.

1 Like

Hi @parham.khojasteh1,

Please write to “camerasolutions@e-consystems.com”, our camera experts will assist you.

1 Like