Missing tensorrt package in isaac_ros_common


I’ve been trying to use tensorrt for a few days now on the Isaac ROS Dev Base docker image, available here. I’ve pulled it on an Orin AGX to run a project that was working previously on a l4t docker image with humble installed on top.

From what I’ve seen in the Dockerfile here, everything is already installed and the paths are all already set. But when I run import tensorrt the package is not found. I’ve tried following the install instruction from the installation guide, I’ve also tried multiple other ways to install tensorrt:

apt update && apt upgrade
apt install nvidia-tensorrt
pip3 install nvidia-pyindex
pip3 install tensorrt

My Orin AGX is running JetPack 5.1.1 and if I search for tensorrt using dpkg -L all I have is results in /usr/share/doc. There is also an executable in /usr/src/tensorrt/bin but I’m not sure what to do of it.

The Isaac ROS Dev Base image is also based on l4t-base so should be pretty similar to your setup. Have you tried running tensorrt in Python3 inside of the container launched through run_dev.sh? There are some mappings and environment variables that may be needed. The images also built with changes to the default Python version too which may be causing an issue here.

Running the container using run_dev.sh and installing python3-libnvinfer* seems to have solved the issue. I will do further tests but I can import tensorrt on python3 now