Mksparse command syntax and apply_binaries error

I’m running the following:
Windows 10.0.19044
WSL Ubuntu 22.04.1. LTS
Jetson Linux 35.1.0

I’ve got some limitations and am unable to get a linux system on bare metal, so I’m using WSL as a stand-in. I created a back up of my Jetson and am seeking to create a sparse image that I can later flash to another Jetson.
I am following the Quick Start Guide and do not get a success statement when I run the apply_binaries script. Instead, I get the following error message chroot: failed to run command ‘dpkg’: Exec format error. I made sure that qemu-user-static is installed on this system.

user@host:~$ ls
Jetson_Linux_R35.1.0_aarch64.tbz2 Linux_for_Tegra Tegra_Linux_Sample-Root-Filesystem_R35.1.0_aarch64.tbz2 jetsonimage nvidia.txt old
user@host:~$ tar xf Jetson_Linux_R35.1.0_aarch64.tbz2
user@host:~$ cd Linux_for_Tegra/rootfs/
user@host:~/Linux_for_Tegra/rootfs$ sudo tar xpf …/…/Tegra_Linux_Sample-Root-Filesystem_R35.1.0_aarch64.tbz2
user@host:~/Linux_for_Tegra/rootfs$ cd …
user@host:~/Linux_for_Tegra$ sudo ./
Using rootfs directory of: /home/user/Linux_for_Tegra/rootfs
Installing extlinux.conf into /boot/extlinux in target rootfs
Root file system directory is /home/user/Linux_for_Tegra/rootfs
Copying public debian packages to rootfs
Start L4T BSP package installation
QEMU binary is not available, looking for QEMU from host system
Found /usr/bin/qemu-aarch64-static
Installing QEMU binary in rootfs
/home/user/Linux_for_Tegra/rootfs /home/user/Linux_for_Tegra
Installing BSP Debian packages in /home/user/Linux_for_Tegra/rootfs
chroot: failed to run command ‘dpkg’: Exec format error

Probably for related reasons the ./mksparse command also does not work and spits back this error.

user@host:~/Linux_for_Tegra/bootloader$ sudo ./mksparse -v --fillpattern=0 ~/jetsonimage/20220811wavijet.raw ~/jetsonimage/system.img
./mksparse: 1: Syntax error: “(” unexpected

Any guidance on this issue would be greatly appreciated

Looks like you are running virtual Linux Ubuntu 22.04 on Windows OS. Is it possible to run 20.04 or 18.04? We generally use host PC in Linux Ubuntu 18.04 and 20.04. We don’t recommend use virtual machine but may give it a try.

I’ll give that a try and then get back to you.

I tried both 20.04 and 18.04 on WSL and received the same error messages. Next I’ll work my way to getting a bare metal machine and figuring it out from there.

Running off of WSL was my issue. Everything works now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.