Mlnx-ofed-all RPM in EL8 libfabric obsoletes issue

I have a customer wanting to use libfabric along with mlnx-ofed-all rpm package in Rocky 8.4. We did not have issues with both libfabric and mlnx-ofed-all being installed together on CentOS 7.x variants. We have found that the new mlnx-ofed-all EL8 rpm contains a obsoletes flag for libfabric, which is why were can’t install both libfabric and mlnx-ofed-all rpm’s along side each other in EL8. We can’t seem to find any documentation on why this flag has been set. Any explanation would be greatly appreciated here. I also don’t see that the mlnx-ofed-all EL8 RPM contains any of the libfabric commands.

[root@ssc-vm-g4-rhev4-0151 ~]# rpm -q --obsoletes ./mlnx-ofed-all-5.4- | grep libfabric
warning: ./mlnx-ofed-all-5.4- Header V3 DSA/SHA1 Signature, key ID 6224c050: NOKEY
[root@ssc-vm-g4-rhev4-0151 ~]#
[root@ssc-vm-g4-rhev4-0151 ~]# dnf --setopt=obsoletes=0 install libfabric
Updating Subscription Management repositories.
mlnx_ofed_rhel8.4                                                                                                                                                                                          24 kB/s | 2.1 kB     00:00
puppet6-el8                                                                                                                                                                                                25 kB/s | 1.8 kB     00:00
EPEL-8                                                                                                                                                                                                     38 kB/s | 2.8 kB     00:00
Rocky Linux 8 - BaseOS                                                                                                                                                                                     39 kB/s | 2.4 kB     00:00
Rocky Linux 8 - AppStream                                                                                                                                                                                  42 kB/s | 2.8 kB     00:00
Rocky Linux 8 - Extras                                                                                                                                                                                     34 kB/s | 2.1 kB     00:00
Rocky Linux 8 - PowerTools                                                                                                                                                                                 45 kB/s | 2.8 kB     00:00
Rocky Linux 8 - ResilientStorage                                                                                                                                                                           37 kB/s | 2.4 kB     00:00
 Problem: problem with installed package mlnx-ofed-all-5.4-
  - installed package mlnx-ofed-all-5.4- obsoletes libfabric provided by libfabric-1.12.1-1.el8.x86_64
  - package mlnx-ofed-all-5.4- obsoletes libfabric provided by libfabric-1.12.1-1.el8.x86_64
  - cannot install the best candidate for the job
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@ssc-vm-g4-rhev4-0151 ~]#

Let me know if I can provide any more details or information. Appreciate the time!

Hi Kevin,

Thanks for posting your inquiry to the NVIDIA Developer Community.

Support for community operating systems (Rocky Linux, Alma, PhotonOS, and others) is not available in MLNX_OFED 5.4- Support for these OSes is only tested and supported as of MLNX_OFED 5.6-

As of this release, we only test and validate Rocky Linux v8.5 and later:
[§ ‘Supported Community Operating Systems’]

For community operating systems, installation instructions can be found here:
[§ ‘Installing OFED on Community Operating Systems’]

Regardless, the fact that libfabric is obsoleted is expected here. libfabric relies on inbox driver packages - MLNX_OFED packages are not compatible with it. To install libfabric would replace the MLNX_OFED-provided libibverbs, libibverbs-utils, rdma-core-devel, ibacm, libibumad, librdmacm, librdmacm-utils, infiniband-diags, srp_daemon, and some others with the versions in the OS repository. As such, we obsolete these packages as part of MLNX_OFED installation.

IB packages coming from the OS vendor repositories are not built against MLNX_OFED libraries, they are built against the OS vendor-provided driver/libraries. If using libfabric is a requirement, you will need to uninstall MLNX_OFED, and use the OS vendor-provided upstream driver/libraries.

I hope that clears things up. If you require further assistance on this issue, please open a support case at (or email

Sam Simcoe
NVIDIA Networking Support

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.