[mmapi] '08_video_dec_drm' got a error in rendering frame

when I running sample 08_video_dec_drm, on TX1 (L4T 28.1) , a runtime error occurs.

[ERROR] (NvDrmRenderer.cpp:639) <renderer0> Failed to flip
[ERROR] (NvDrmRenderer.cpp:656) <renderer0> Error in rendering frame

My step is

1, configure the environment variable

export DISPLAY=:1.0

2,To run

./video_dec_drm ../../data/Video/sample_outdoor_car_1080p_10fps.h264 H264

Hi Li, shouldn’t it be ‘export DISPLAY=:0’?

Hi DaneLLL,

Since I updated L4T 28.1, ubuntu user’s default display device becomes 1.0, if I use the command ‘export DISPLAY=:0’, The same thing as before, will print the same error.

I use the command ‘export DISPLAY=:0’ to run ‘02_video_dec_cuda’, will print:

Invalid MIT-MAGIC-COOKIE-1 keyErro while initialize EGL display connection

Use ‘export DISPLAY =: 1.0’ to work properly.

Hi Li, can you try to run the samples with nvidia user? On r28.1(actually starting from r27.1), ubuntu user is limited to access DISPLAY.

Hi DaneLLL,

I tried nvidia user, and sudo.
There is no effect.

Hi li_lin,

Please turn the X-server off while running this sample.

sudo service lightdm stop

Guidance is at https://developer.nvidia.com/embedded/dlc/l4t-release-notes-28-1

thank you for your help :)