modeset=1 + xserver-1.19.4 won't work

Unlike my previous report, this is about using the laptop in hybrid mode.
No kernel crash, but there is no display, just a black screen.

nvidia bug report attached.
nvidia-bug-report.log.gz (66.8 KB)

An update. Actually, the display eventually gets to the login greeter, after a minute of a black screen with mouse pointer. On the greeter there is a delay of 30 seconds between the recognition of each keystroke. It is practically impossible to enter a password and login. Never seen this before.

If you are using crapware eg: GDM you will need to disable wayland in /etc/gdm/custom.conf

Does it work with modeset=0?
Please run nvidia-bug-report.sh when X finally came up, maybe some timeout messages are visible then.

I have reverted to lightdm. With modeset=0 it is normal.
apart from the delay and the very slow keyboard response, I also get a frozen image of the pointer after I move it (so I the frozen pointer, the the moving one, which is as smooth and responsive as normal).
Attached is a bug report snapshot taken from a console after the greeter appears.
nvidia-bug-report.log.gz (67.5 KB)

that’s odd, I have booted with integrated graphics, and I seem to be missing a file which is always previously present, nvidia-graphics-drivers.conf

Then I know this, it’s an incompatibility with the last xserver 1.19.4 update. I reverted to 1.19.3 for now until I find more info about that.

something is broken with ubuntu packaging perhaps. A purge and resinstall still does not fix this, but there are syntax errors during the install. I copied the file from my other thinkpad. It behaves normally now, but I have tearing, even though I have done what I usually do to enable modeset=1
nvidia-bug-report.log.gz (75.1 KB)

I don’t know what you broke now, but it’s running with modeset=0 so there’s tearing but it works.
The issue that xserver 1.19.4 doesn’t work with modeset=1 has nothing to do with ubuntu packaging, I’m using Gentoo so my xserver is compiled from official sources.
Since on my system the symptoms are similar but different, I was looking in the direction of systemd-logind before. I didn’t suspect the nvidia driver and modeset. The logs are all clean, just like mine so it was hard to find the culprit.
Now that I know I can start to bisect the xserver if I find some hours time to find the responsible commit.
The conclusion for now is just: modeset=1 + xserver-1.19.4 won’t work.
Please change the subject of this thread to reflect that so some nvidia dev might get attracted.

I got my frozen mouse pointer and no keyboard response back via a console rmmod nvidia-drm; modprobe nvidia-drm modeset=1 which proves the problem had nothing to do with the missing .conf file

I have no idea what’s going on but it sounds like you do.

Found the culprit, opened a bug with freedesktop.org
https://bugs.freedesktop.org/show_bug.cgi?id=103243
I’m attaching a revert.patch in case anyone who compiles his own xserver wants it.
revert.patch.txt (16.6 KB)

Luckily, Xorg had some security fixes queued at the same time so they pushed out xserver-1.19.5 some hours ago including the revert fix for this. So this should land soon in distros. Until then, use modeset=0 and bear the tearing.

Xserver-1.19.5 is in Arch repos.

It works again, no freeze anymore !

Thank for bug reporting.

If not working for any reason, it’s not needed to use modeset=0, just disable the PRIME Sync with xrandr --output $output --set “PRIME Synchronization” 0