Monitors will not stay asleep in any distro I've tried

Hello everyone, I’ve got 2 monitors connected via display ports. In every distro I have tried, the monitors will not stay asleep after the allotted time via power management settings. Both monitors power off, but after a few seconds power back on.

Some things I have tried:

-Different distros:

Manjaro plasma - running from usb
Pop!_os - running from usb
Garuda xfce - running from usb
kubuntu - running from usb
mint cinnamon - running from usb AND installed onto external drive, updated software and updated video drivers

-Unplugged all peripherals - mouse, keyboard, xbox controller

-Could this be related to my APC UPS? I have not tried plugging the pc or monitors into a different power source

-Could this be an issue with some setting in my BIOS?

-I have had this same issue on a completely different PC using Garuda plasma, issue was resolved after installing Manjaro plasma.

-I do not have this issue in Windows 10 or Windows 11

My system specs:

[code]
System:    Kernel: 5.4.0-91-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 5.0.7 
           wm: muffin dm: LightDM Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal 
Machine:   Type: Desktop System: Gigabyte product: X299 UD4 Pro v: N/A serial: <filter> 
           Mobo: Gigabyte model: X299 UD4 Pro-CF v: x.x serial: <filter> 
           UEFI [Legacy]: American Megatrends v: F6 date: 10/02/2019 
CPU:       Topology: 10-Core model: Intel Core i9-9820X bits: 64 type: MT MCP arch: Skylake rev: 4 
           L2 cache: 16.5 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 131999 
           Speed: 1200 MHz min/max: 1200/4100 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1200 
           4: 1200 5: 1200 6: 1200 7: 1201 8: 1302 9: 1201 10: 4000 11: 1201 12: 1200 13: 1200 
           14: 1200 15: 1200 16: 1300 17: 1200 18: 4112 19: 1200 20: 1200 
Graphics:  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti] vendor: ASUSTeK driver: nvidia v: 470.86 
           bus ID: 65:00.0 chip ID: 10de:1e04 
           Display: x11 server: X.Org 1.20.11 driver: nvidia 
           unloaded: fbdev,modesetting,nouveau,vesa tty: N/A 
           OpenGL: renderer: NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.86 
           direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
           Sound Server: ALSA v: k5.4.0-91-generic 
Network:   Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k port: 3000 
           bus ID: 00:1f.6 chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel 
           port: b000 bus ID: b3:00.0 chip ID: 8086:24fb 
           IF: wls1 state: down mac: <filter> 
Drives:    Local Storage: total: 7.30 TiB used: 19.28 GiB (0.3%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> 
           ID-2: /dev/sda vendor: Toshiba model: MD04ACA600 size: 5.46 TiB speed: 6.0 Gb/s 
           serial: <filter> 
           ID-3: /dev/sdb type: USB vendor: Western Digital model: WD10TMVV-11A27S2 
           size: 930.86 GiB serial: <filter> 
Partition: ID-1: / size: 914.75 GiB used: 19.28 GiB (2.1%) fs: ext4 dev: /dev/sdb5 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 chip ID: 1d6b:0002 
           Device-1: 1-3:2 info: Razer USA Razer Naga Trinity type: Mouse,Keyboard 
           driver: hid-generic,usbhid rev: 2.0 chip ID: 1532:0067 
           Device-2: 1-7:3 info: Western Digital My Passport Essential (WDBAAA) My Passport for 
           Mac (WDBAAB) My Passport Essential SE (WDBABM) My Passport SE for Mac (WDBABW 
           type: Mass Storage driver: usb-storage rev: 2.0 chip ID: 1058:070a 
           Device-3: 1-13:4 info: Intel type: Bluetooth driver: btusb rev: 2.0 chip ID: 8087:0aa7 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Device-4: 3-1:2 info: Razer USA BlackWidow Ultimate 2013 type: Keyboard,Mouse 
           driver: hid-generic,usbhid rev: 2.0 chip ID: 1532:011a 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 chip ID: 1d6b:0003 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //linux-mint.froonix.org uma main upstream import backport
           2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 374 Uptime: 1h 08m Memory: 31.07 GiB used: 2.26 GiB (7.3%) Init: systemd 
           v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client 
           inxi: 3.0.38 
[/code]

nvidia-bug-report.log.gz (493.3 KB)

I SOLVED IT! The issue had something to do with my APC Uninterruptible Power Supply (UPS). One display was plugged into the battery section using a USA to UK power adapter, the other display was plugged into just the surge protector section, with no adapter. I think the issue was happening due to an eco power saving mode, but I don’t know exactly. Power saving features and other settings on the monitors appeared to have no effect. This issue was also causing a different issue on Windows 11, which would seemingly cause the second monitor to disconnect completely, as if it had been completely unplugged, moving all of my windows and generally taking its time powering back on when the mouse was moved or a key pressed. To others having this issue, try plugging your monitors into a separate power strip by themselves, or straight into the wall outlet. Also, try setting your power settings to the lowest timing (mine was 1 minute), and keep the monitor menu open while the displays power off to see how they react.

Again, I don’t know exactly what was causing this to happen but it had to do with the power, not the monitor settings, OS, or other hardware.

My monitors (can’t find the exact model of the LG):

LG ultrawide 1080p 144hz

VIOTEK GNV34CB