Monitors wont resume from standby

Card: MSI 1080 Ti
NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)
Driver: 384.69
Mobo: MSI X399 Gaming Pro Carbon AC
Monitors: 3 ASUS MG28UQ
OS: Ubuntu 17.04

When the monitors go into standby or power saving mode, they will not properly re-initialize and come back on. Sometimes they are completely unresponsive, sometimes only the middle screen comes back on. But after logging in the desktop is not displayed properly and is stretched horizontally and only on the middle screen. does get me to tty1 and all screens mirror the proper tty1 display. returns me to the same non-working GUI display.

Attempted workaround:
In Unity I have disabled “Turn screen off when inactive for” options under Settings->Brightness & Lock

Same results.

I have ssh’ed into my desktop from another machine and generated 3 error log reports. One after the monitors have shut off, one after an unsuccessful wake up, and one after switching to tty1.

It appears DPMS is on, so I’m thinking if I turn it off, that could be a work-around.

xset -dpms

However, is there a way to get power saving standby mode to work with this GPU and Monitors?

Thank you!

Error log files are at:

Disabling DPMS is a workaround.

$ xset -dpms
$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  5/1    threshold:  5
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

I no longer have to re-start my GUI after an extended period away from the computer. My screens blank, but they never go into power saving mode. So it’s still not an ideal solution.

I have this problem too. I’ve had it with multiple computer builds. The only thing in common is my monitors. I have two ASUS MG28U’s. Really hoping for a fix.