More than 4 monitors in Linux?

Ok, please change the config file replacing “21” with “33”, i.e.

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:33:0:0"
  Option "BaseMosaic" "true"
  Option "AllowEmptyInitialConfiguration" "true"

If it still doesn’t work, please create a new nvidia-bug-report.log.

Looking at the logs again, I guess I misunderstood your problem. You’re only seeing 2 monitors connected on one gpu while 3 are physically connected. I guess this comes from the fact that you’re using passive DP to HDMI 2.0 converters. I don’t really know if the gpu supports more than 2 hdmi devices, does this also occur if you connect at least one real DP monitor?

I made the change and rebooted. Ran nvidia-settings and it still only sees 4 monitors. Attaching a new bug report. nvidia-bug-report.log.gz (1.5 MB)

Just curious but why the 33 for the busid? lspci shows:

[root@okc-exp2-cwp-05 ~]$ lspci |grep -i vga
00:1f.5 Non-VGA unclassified device: Intel Corporation 200 Series/Z370 Chipset F amily SPI Controller
15:00.0 VGA compatible controller: NVIDIA Corporation GP107GL [Quadro P400] (rev a1)
21:00.0 VGA compatible controller: NVIDIA Corporation GP107GL [Quadro P400] (rev a1)

lspci displays hex, xorg wants decimal values 0x15=21dec

Yes, I’m using DP to HDMI converters on all 5 monitors. I didn’t know about the hex->decimal thing, that’s good to know for the future!

Does the missing monitor show up if you disconnect any of the other displays? I.e. try booting with just the non-working monitor connected and see if it shows up, and then if it does, start adding back other monitors before booting one at a time to see if adding a particular one causes the other to stop working.

I’ll give that a shot now and reply shortly, but I wanted to add that when I was playing around with this last week, the monitor that doesn’t work would move after a reboot. Also, the main monitor that displays POST also moves when rebooting.

Did it just move around on subsequent reboots without changing the hardware configuration? That sounds like the monitors (or the HDMI dongle) aren’t responding consistently.

Normally I’d try this myself but I don’t have access to this hardware due to the pandemic. I can file a bug to get QA to try it, though.

So in the current config, monitor 2 was not working. I unplugged the others and rebooted but monitor 2 still didn’t work. So next I moved monitor 2 from the second port on the first card, to the first port and that monitor started working.

Next I plugged a monitor into the second port (where monitor 2 was) and rebooted. When it came up, the monitor in port 1 was seen and working, but the monitor in port 2 was not seen by nvidia-settings

I edited that last sentence it was incorrect before.

Sorry, my last message doesn’t make sense, let me try once more:

I booted with just monitor 2 plugged into port 2 and it did not work. I moved monitor 2 to port 1 and it worked. I added monitor 1 to port 2 and rebooted but monitor 2 in port 1 doesn’t work, even though port 1 worked before.

So right now I have two monitors plugged in but only one is seen.

Yes, I’m just powering it off, unplugging/plugging or moving monitors and powering it on. Should I be doing something else between reboots?

No, that’s what I was asking for. Basically to narrow down whether the problem is with one specific monitor, HDMI dongle, or cable, or if the problem is specific to a particular port on the GPU and depending on which other devices are attached.

I’ll file a bug and see if I can find someone to try this combination of devices.

I unplugged everything and as I plugged each mini-dp-to-hdmi converter into each monitor, the monitor recognized something was plugged in. Between the 2 cards, I have 6 ports, lets call them 1-6.

With the monitors plugged in like this:

Card port / Monitor
1 / 1
2 / 2
3 / 3
4 / 4
5 / 5

monitor 2 doesn’t work. If I moved monitor 2 to port 6 and reboot, monitor 2 still does not work.

If I plug monitor 2 into port 1 and boot it with just that monitor, that monitor works.

For extra credit, I mixed them all up to see if the problem moves around:
Card port / Monitor
1 / 3
2 / 4
3 / 2
4 / 5
5 / 1

In this configuration, monitor 2, which is in port 3 still doesn’t work. If it wasn’t for the fact that monitor 2 works by itself, I would think its a bad monitor?

Does that help at all?

Yeah, that’s definitely interesting. These monitors are all identical, right? There must be something interesting about monitor 2. Are all of the settings in the OSD the same across these monitors? Also, if there’s a way to check can you please see if they all have the same firmware version?

Yes, all of the monitors are the same. However, I just made a slight break through…

I disconnected monitor 2 and in its place I connected a Dell monitor using mini-dp to standard dp and now I have 5 monitors. Next step is to add monitor 2 back in and see if it works. Be right back.

So now powering it up with 6 monitors (5 asus hdmi and 1 dell DP) and monitor 2 still doesn’t work. As one last test, I unplugged monitor 1 and plugged monitor 2 in its place and now monitor 2 is working as well as the other 4.

So I’m not sure what that means. I believe it means all of the hardware is working (monitors, cables, converters) but I just can’t have 5 asus monitors? But I can have 4 asus and 1 dell? Or is it that I can’t have 5 HDMI monitors? 4 HDMI and 1 DP seem to work. Asking because I have to explain all of this to someone else.

EDIT: Even though monitor 2’s light was blue, it was not listed in nvidia-settings when I checked further. So I put monitor 3 back in place and its working.

EDIT2: I think its a bad converter. When I switch adapters monitor 2 works fine. The weird thing is that converter works fine when its the only monitor connected.

EDIT3: It was a bad mini-dp to HDMI. I’m not sure why it worked fine when used without the other monitors, but replacing it fixed the issue. Thank you for all of your help! I learned a few good things here. Sorry for all of the edits, but it says I can’t post again until tomorrow.

Thanks for getting to the bottom of that! It’s still weird that it worked as the boot display but not after the driver loads, but these kinds of adapters can be really flaky in general so I think we can just chalk it up to the adapter being quirky.

I cleared the “new user” flag in the admin panel so you should be able to post normally now.

add nvidia-drm.modeset=0 to your kernel params.

Maybe that decision also expanded to Quadro GPU’s as well?

Though there are people claims Windows side doesn’t have such restriction anymore, maybe that comment is also not valid these days.

It was just a broken cable.
BTW, the BaseMosaic limit on GeForce was lifted to 5.

Ah, ok. Missed the last edited message of his.

Nice to know!